External hard drive letters

By Cabbage1031
Jul 13, 2011
Post New Reply
  1. I have two identical external hard drives. 1 is hooked up to a server and a nightly backup is copied to the hard drive. Every so often, my boss likes to take the current backups home and attach the other hard drive to the server, which then backs up nightly. This way he always has a copy at home and at the office. Problem: When he switches the hard drives, the partitions are not automatically named with a drive letter, therefore they do not backup nightly. I can go into disk management and assign a drive letter without a problem. But my boss wants this done automatically. Any thoughts, I would like to be able to keep my job. Thanks.
  2. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    First, what version of OS is this happening on?

    I'm fairly sure there is a way to disable/enable automatic drive letter assigning, however I can not think of it and it will depend on the OS where this option lies. Please update with the information and I will research the issue further.

    Edit: I found this website after a few seconds of searching, might be helpful:

    Although in your case you will probably want to ENABLE this, not disable.

    Post back with Results, thanks.
  3. jobeard

    jobeard TS Ambassador Posts: 9,351   +622

    You might find this information to be helpful - - but in reverse.

    In your case, your backup software is looking for DLA x and regardless of which physical drive is available, it *MUST* be x

    take this info to delete the scruff from the HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices, and then go back and intentionally create the conflict for these two drives. This will obviously then prohibit both being attached at the same time, but your backup process will work regardless :)

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...