TechSpot

External HDD not formatting

By Photo601
Apr 28, 2008
  1. Greetings. I have a WD 500 GB SATA drive I have put into a Thermaltake Esate enclosure. (Thermaltake EA3006 Aluminum External Enclosure) The first drive I had would not format in the enclosure, nor would it format internally. I RMA'd the drive and was trying to install it i\n the enclosure. It would not format using PM8. I have not used the Linux partitioning program a friend has. I tried formatting from a boot disk but PM would not format the drive. I tried PM8 from Windows to no avail. I uninstalled the drive, then reinstalled the drive in Dev Mgr. I tried formatting again and it gave me the BSOD.
    I am running an Evga 680i, 2 additional hard drives, a 500GB WD and a 200GB WD. I wanted the 3rd drive a s a backup for my other computer that's dying. I don't think my board supports Esata natively. The enclosure attaches to an internal sata connection and the power from a molex connector.

    :confused:
     
  2. JesseM

    JesseM TS Enthusiast Posts: 259

    This might be a stupid thing to say, but I just got myself an external enclosure and was having troubles until I put the jumpers on master, after which it worked fine. Give it a try if you haven't already. Good luck.
     
  3. Photo601

    Photo601 TS Rookie Topic Starter Posts: 80

    I didn't think SATA used jumpers.


    I was thinking it was relative to where you connected the SATA cable internally.
     
  4. JesseM

    JesseM TS Enthusiast Posts: 259

    You're probably right, after all my external enclosure is for IDE drives.

    Another excellent tool I have found useful for just about anything to do with hard drives is called TestDisk and it is freeware.

    http://www.cgsecurity.org/wiki/TestDisk

    Hope it helps.
     
  5. nickc

    nickc TechSpot Paladin Posts: 1,650

    when in Windows is the drive in the enclosure recognized if it is just right click it in my computer and then click format. give it time as it will be slow in the enclosure to format.
     
  6. Photo601

    Photo601 TS Rookie Topic Starter Posts: 80

    When I right click into My Computer, no, it doesn't. I can see it in Disk Magement, but Windows pops up with a request to format the drive dynamically. I want to be able to partition it, and from what I have read about dynamic drives, they can't be pertitioned. I do not plan on running RAID either.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.