External HDD not working on Mac - can't erase disk

By Grixti
Oct 20, 2010
Post New Reply
  1. Hi there,

    I recently bought a Samsung Story Station 1TB. I need it to be Mac OS Extended so that I can write files over 4gb as I am working with HD video.

    I tried formatting the HDD to Mac OS Extended and it failed. Now when I connect the HDD I get an error message saying that Disk insertion is not readable by this computer.

    When I use Disk Utility and try the standard erase disk (not zeroing out) I also get an error message saying disk erase failed.

    Also, under the Samsung HD in the left hand side of the disk utility there is a sort of sub folder. I am guessing this is some sort of partition. This is grayed out but it does say that it is Mac OS Extended. If I try to erase this I also get the same error message.

    If anyone could give me some advice on how to get this hard drive up and running so I can use files larger then 4GB on my mac I would really appreciate it.

    Dan
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,287   +225

    In Disk Utility, select the drive, then go to the partition 'tab' and select the partition (you select the drive on the left, the 'sub folder' is the partition). Once you have the partition selected, hit the "-" button below it to remove the partition. Then select all that blank space and and click "+" to create a new partition. I don't have a free drive to play with so I don't know exactly what happens when you create the new partition, but I think it allows you to select what to format it as, Mac OS Extended should be the default.

    This should do it for you.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.