Fan speed erratic

By fw2004
Jun 26, 2009
  1. Hi;
    My system, which I built 4-1/2 yrs ago is an Asus P5AD2E Premium with Antec True Power 550 watt PSU, and I have a 120mm fan in the rear that is now starting to act up.
    It is connected to the "fan only" connector coming from the PSU, and min speed can be varied by a front panel control.

    Everything has been working perfectly until a couple months ago when the fan speed started varying up and down erratically.
    The only time it does not vary is if I have the fp pot turned fully CW so it runs at max speed all times.
    Normally, the fan is supposed to vary speed depending on need for cooling, and this feature has worked very well until now.

    I found that if I turn up the +12V supply from about 12.1 to 12.3V, the fan slows down. But it still runs erratically.

    I am going to open up the PSU to see if I can find any loose connections.

    Any ideas?


  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    Remove it from the fan controller and run it directly from the motherboard or power supply. If it still runs erratic, replace it
  3. fw2004

    fw2004 TS Enthusiast Topic Starter Posts: 150

    I have a feeling that it will indeed run fine when connected directly to +12V.
    I have the FP min speed control fully CW now, the fan is running constantly at high speed, not varying at all.

  4. raybay

    raybay TS Evangelist Posts: 7,241   +9

    Replace the fan. You are asking too much of those little bearings to run them on and on for 54 months... You should be replacing all fans every 18 months, at a minimum.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...