FDD Problem

By zalophus
Apr 9, 2008
  1. Sony MPF920 FDD, has worked fine since build in January. Shows up in BIOS and "Computer", and Device Mgr shows driver current, and "device is working".

    New Problem: Inserted discs are not recognized-I keep being asked "to insert a disc in drive". I have tried different discs, and swapped out FDD and problem remains. Boot priority shows FDD as first choice, but when I insert disc pre-boot, the boot process doesn't recognize any disc in FDD.

    I have reset bios to "Fail Safe", and "Optimized settings" with no effect.

    I have no idea what has happened or when.

    Feels like a MoBo problem, but...?

    Help appreciated.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Probably has dust in the drive, or the data cable connection is not fully secure
    Please confirm both of those possibilities.

    Also you mention Bios defaults, but did you also confirm boot sequence priority too?
    Obviously Floppy enabled 1.4Meg

    Lastly you could try a bios reset from your motherboard jumper (you may need to download your manual to locate this jumper (usually near the CMOS battery) and what to do exactly (usually remove jumper, and possibly insert into pins 2&3 for 10 secs) Obviously with all power out.

    One more thing.
    It could just be a faulty floppy drive! That now requires replacing.
  3. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,689   +395

    You didn't plug the cable in upside down did you?

    When looking at a computer with the left side of the case off, IDE drives have the PIN 1 indicator (red stripe on cable) nearest to you. Floppy drives have that on the other side, furthest from you.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...