Fedora Core - 1st time use, basic questions

By TDawg
Aug 8, 2006
Topic Status:
Not open for further replies.
  1. I decided to go ahead and install fedora core again today, I'm not sure exactly what version it is (I don't think it's fedora core 5) I'm dual booting that and XP pro. All seems to be going pretty well except for a few problems... I have an audigy 4 pro sound card, linux detects it, and give me the "sample sound" but I can't hear anything. Creative has no linux drivers on their website for this card either. Another problem is nvidia graphic drivers. I have 3 choices on the nvidia site for linux. IA32, IA64, and Linux AMD64/EM64T. Now as I said before I'm not sure which version of fedora core this is, but I don't think it's completely 64-bit, so I would guess to download the "IA32" I download it to the desktop and double click it to install it. But I get an error saying it couldn't open because gedit was not able to automatically detect the character coding...etc. It gives me the same error with IA64 as well. So I try to install it through terminal by typing "sh NVIDIA-Linux-x86-1.0-8762-pkg1.run" but that doesn't work either. Help would be great. thanks.
  2. TDawg

    TDawg Newcomer, in training Topic Starter Posts: 154

    ok I've been messing around and tried to install the 32 bit version of the nvidia gfx drivers, turns out the .run file can't just be sitting on the desktop, once I moved it to the home folder, I tried installing from the terminal, but it says I appear to be running an x server and I need to exit it before installing. So from the nvidia site I downloaded nvidia-xconfig. It's an archive file so I uncompressed it and I don't really know what to do with it after that
  3. Didou

    Didou Bowtie extraordinair! Posts: 5,899

    Go into text mode (runlevel 3), login as root (or use the "su" command), install the nVidia drivers & restart the X server (runlevel 5).
  4. TDawg

    TDawg Newcomer, in training Topic Starter Posts: 154

    how do I go into text mode (runlevel 3), I logged out and went to session, then failsafe terminal thinking that was text mode and tried to install from there but got the same error.
  5. Didou

    Didou Bowtie extraordinair! Posts: 5,899

    Hit CTRL+ALT+F1, that should bring you to a doslike console asking for a username. Login as root & then type init 3. Launch the nVidia installer & once done, type init 5.
  6. TDawg

    TDawg Newcomer, in training Topic Starter Posts: 154

    I get to the console, login as root, then type init 3, but then it has about 3 lines of something that starts up with [OK] next to it. then I can't see anything I type, I'm not sure if it's letting me type or not, so I try to install the nvidia driver from there, nothing happens, and I type init 5, exit, randon things...nothing happens
  7. TDawg

    TDawg Newcomer, in training Topic Starter Posts: 154

    after I type init 3 and go to that next screen, I can actually type, it's a little tricky, because the cursor can't be showing or something, idk but after I get it typed out, it should look like "sh NVIDIA-Linux-x86-1.0-8762-pkg1.run" without the quotes, after you press enter, nothing happens.
  8. Didou

    Didou Bowtie extraordinair! Posts: 5,899

    Once you do init 3, there's a command to clear the screen, I believe it's clear. To launch the installer, go into the foler where you downloaded the file & type: ./NVIDIA-Linux-x86-1.0-8762-pkg1.run (do not forget the . in front of /). If nothing happens, maybe you've changed the file attributes & it is no longer flagged as a binary file.

    ps. have you downloaded it into an ext2/3 folder or on a Fat32/ntfs disk ?
  9. TDawg

    TDawg Newcomer, in training Topic Starter Posts: 154

    ok, I get to that screen after I type init 3 and from there no command will work, after you press enter, it just takes you down to a new line. But on the previous screen after logging in as root, I type ./NVIDIA-Linux-x86-1.0-8762-pkg1.run and then it tells me I don't have permission. I don't remember changing file attributes...it's a fresh install of fedora core 4.


    I downloaded the nvidia driver into the home folder. I think that's what you are asking. Thanks for the help so far.
  10. TDawg

    TDawg Newcomer, in training Topic Starter Posts: 154

    alright I figured it out with your help of course. After you log in as root and type init 3, you then need to push alt+f7 to take you back to the previous screen, then you can start the nvidia installer. Also I got the audio to work just by messing around with some settings in the volume control.

    Now I have an extensive music and movie collection, but it's in ntfs, is there any way to access these files from that hard drive from linux?
  11. Didou

    Didou Bowtie extraordinair! Posts: 5,899

    This is where the search feature of the forums become handy because this subject has been discussed quite a lot already.
     
  12. TDawg

    TDawg Newcomer, in training Topic Starter Posts: 154

    ok so now everything is all good, I can access my ntfs partition but the only thing I need to be able to do is get to the partition on other accounts besides root, and also all of my music is in mp3, I haven't checked yet on here to see if it's been discussed, I'll do that when I get a chance, but if not I appreciate the help
  13. TDawg

    TDawg Newcomer, in training Topic Starter Posts: 154

    I've got the mp3 situation worked out, now the only real problem I'm having is having that partition be mounted automatically on boot up, and also so my normal login "TDawg" can have access to the partition. I've been getting help from http://wiki.linux-ntfs.org/doku.php?id=ntfs-en#how_do_i_mount_an_ntfs_volumes_automatically in section 4.10 but I don't understand the commands, when I use them on the root account I get an error saying "permission denied"
  14. TDawg

    TDawg Newcomer, in training Topic Starter Posts: 154

    so I'm trying to use the Noatum media player but it doesn't seem to want to play any of my music, all I have is mp3's so it might just be those. also from root I can't write on that NTFS partition, I can only read. And I still can't access the partition from other accounts besides root. And I still would like for it to be mounted automatically on boot up.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.