File permissions on dual boot system

By lopdog
Oct 12, 2010
Post New Reply
  1. Hi!

    I'm currently using a dualboot configuration on my laptop, with Windows XP x86 on the first partition and Windows 7 x64 on the second. I have mostly the same programs on both systems, but when I create/edit a file with XP, and then open it with the same program in Win7, I get read-only access. Then I have to enter file properties and give myself complete access, or save the file with a different file. This is anoying. Is there any easier way to solve this?

    BTW, I created a folder for all my documents on the first partition (called "C:\documents" under winXP and "D:\documents" under Win7), to make it easier to find my stuff.
  2. jobeard

    jobeard TS Ambassador Posts: 9,143   +597

    use the Shared Documents folder instead
    \Documents & Settings\All Users\Shared Documents
  3. brucethetech

    brucethetech TS Enthusiast Posts: 229

    bingo joe. this is ntfs permissions doing their job. you have two different user accounts on those OS's (or whatever...oses or O.S.'s). You can also give everyone access to that folder (bad, bad, bad, but easy). if it truely matter to you, you can create the account that you use to log into XP on the 7 install and give that user access to the files. this is the best practice. so you can avoid using the "everyone" group
  4. lopdog

    lopdog TS Maniac Topic Starter Posts: 295

    Ok, thanks, I'll try with the shared folder. Should I use the shared folder from XP or 7?
  5. jobeard

    jobeard TS Ambassador Posts: 9,143   +597

    PS: The Shared Documents folder (on all MS systems) uses the Everyone group
    and when Filesharing(FS) is active, is accessible from external systems.

    Using multiple partitions on one system doesn't need FS, but is still controlled by NTFS perms.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...