Firefox 3.0 and Logitech.com issue

By Captain828
Jul 13, 2008
Topic Status:
Not open for further replies.
  1. For whatever reason, I can't open Logitech's website in FF3; it works fine in IE7 though. I just get a blank page, but I can see the logitech favicon in the tab

    I tried clearing the browser cache and cookies but it doesn't work :(

    ... and no, i don't have any other website problems, they all load just fine, so no DNS problems

    Logitech forums however work fine

    is anyone else experiencing this problem? how can I fix it?

    Thx in advance!
  2. Blind Dragon

    Blind Dragon TechSpot Evangelist Posts: 4,048

  3. Captain828

    Captain828 TechSpot Guru Topic Starter Posts: 277

    no, still a blank page

    there has to be something wrong with my browser, someone said something about the javascript security or something like that; don't know exactly what he meant, perhaps someone more specialized (a web dev?) knows
  4. Blind Dragon

    Blind Dragon TechSpot Evangelist Posts: 4,048

    hopefully - is your java run time up to date

    Start -> Control Panel -> Java -> update tab -> check for updates

    if one is found you should install it regardless (latest version is Java 6 update 7)

    Then go to control panel -> add/remove programs (programs and features) -> and uninstall the older versions.

    ------------------------------------------------
  5. Captain828

    Captain828 TechSpot Guru Topic Starter Posts: 277

    I did that and uninstalled previous versions, but it's still not working...
  6. Bobbye

    Bobbye Helper on the Fringe Posts: 16,392   +32

    I get the page to load also in Firefox 3. Check the Java settings:

    Tools> Options> Content> Check 'enable javascript' and Check 'enable Java'.

    See if that makes a difference.
  7. Marvin

    Marvin Newcomer, in training Posts: 56

    Works for me to as much as I hate Logitech for a wireless mouse and keyboard that cost loads and that both eat batteries as fast as as a drumming bunny could .... plus said keyboard that doesn't work until the system has booted up! (just wait until you need to get into safe mode and the F8 key doesn't respond!)
  8. Captain828

    Captain828 TechSpot Guru Topic Starter Posts: 277

    @Bobbye: no dice

    @marvin: i have an USB G15 keyboard and i have no problems "browsing" through the BIOS

    also, my MX Revolution keeps charged for ~3days of intense gaming, and recharges @ full in 20min

    unfortunately, they do cost more than your $10 mouse + keyboard, but their functionality and ergonomics is top grade. In the end it's all about tastes... and needs.
  9. Bobbye

    Bobbye Helper on the Fringe Posts: 16,392   +32

    Curious. Have you tried going to the homepage from the forums?

    When you say you can't access the page, what happens? Do you see 'done' in bottom left corner but no loaded page? Any message at all?

    You can check the Event Viewer and see if there is an Error that corresponds to the time of the failed load.
  10. Captain828

    Captain828 TechSpot Guru Topic Starter Posts: 277

    did that too, but I get the same thing: a blank page, no error msg, nothing

    event viewer says nothing about logitech.com
  11. Bobbye

    Bobbye Helper on the Fringe Posts: 16,392   +32

    One more suggestion. If you are trying to access the site from a shortcut or Bookmark, that may be the problem:

    Try this in the Address Bar: http://www.logitech.com/
    If this accesses the page, delete the temporary internet files, History and Cookies, delete on previous shortcuts and Bookmarks and set new from the site.
  12. Captain828

    Captain828 TechSpot Guru Topic Starter Posts: 277

    hhm... no, I type it directly
  13. Bobbye

    Bobbye Helper on the Fringe Posts: 16,392   +32

    I'm running out of suggestions! But these are my last ones:

    1. Check the Event Viewer-again-for ANY Errors that occur when you have the failed load. (also, all you're said is that it won't load- exactly what happened when you try to access it? Does it say 'Done' with a blank screen? Does the hour glass keep spinning? Does it time out? Does it give any message at all? "Something" happens- what?

    2. In Firefox> Tools> Options> Privacy> Cookie section> Exclusions> make sure this site isn't blocked.

    3. You mention loading this site from a tab. Close ALL your tabs except for one- type http://www.logitech.com/
    in the Address Bar> Go. Anything?

    If none of this works, you will need to look at the add-ons/extensions you have on Firefox. IT is possible that one of them may be blocking the site. Best way is to remove one at a time, close FF, reopen and try to access. Follow this same order with each add-ons and see of you can find a culprit. Remember, the add-on won't be uninstalled until you close, then re-open FF.
     
  14. Captain828

    Captain828 TechSpot Guru Topic Starter Posts: 277

    First off I really want to thank you for your help :)

    1. The event viewer still pops out nothing; also I said that I get a blank page, not that it doesn't load (I've attached an "image", if you can still call it an image :dead:); one weird thing is that if I try to view the page's source code, it's a blank! so it's gotta be something w/ my FF

    2. I've already gone through that and it's not blacklisted

    3. failed; got the "blank page of death" again :haha:

    disabling the add-ons still didn't change the situation at all

    I've never had problems with Logitech.com in FF2, but since going to FF3 (since early Beta 2 I think) I get this BPOD... sure, I can live with IE for logitech.com to get my drivers, but this sure is frustating
  15. Bobbye

    Bobbye Helper on the Fringe Posts: 16,392   +32

    Don't know what else to do except to tell you to delete temporary internet files, History and Cookies. As I'm sure you know, sometimes work on a site will cause a failed load if old files on on the system.

    Also, check your download folder-Tools> Downloads-and make sure you have the final V3,. not the RC3. I got the RC3 by mistake and had some problems. All were resolved once I got the final.

    Since it's only the one site-that I know of-We probably shouldn't get too much more involved. It's NOT FF3- only if an add-on to FF3 is causing the problem.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.