TechSpot

Firefox: How to disable search from address bar?

By billyellis
Sep 30, 2008
  1. OK, this is driving me crazy. I hate having my typos redirected to search pages. I have always hated searches being run automatically without my express consent. And for all the crap that goes with IE, at least you had the option to disable the search from the address bar.

    I also tried to disable the search suggestions (for when you actually are in a search window) by changing browser.search.suggest.enabled to false, but even after restarting FF the search suggestions still pop up.

    Here's what I am looking for: when I type something into a box, I want NOTHING to pop up with any suggestions. I am not an 80-year old AOL user. I can type. I don't need a list of suggestions after every letter I add to my search string or URL. It's f-ing irritating.

    I went through all config settings under the "search" filter and tweaked them where I thought it might help (e.g. removing entries for defaultenginename, order.1, order.2), but nothing worked.

    Using "browser" as the filter, there are several more instances of google that show up under these:

    browser.contentHandlers
    browser.safebrowsing


    So that looks promising, but I don't want to go messing around blind with too many settings.

    Can someone please tell me how to disable all automatic searches and pop up search suggestions in FF (2.0.0.17, running on XP Home)?? I went to the FF forum, but the search disable entries I found there were all for pre-release beta-versions of 3.0.

    Thanks.
     
  2. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    I think it's Java or Javascript that does it (one or the other!)
     
  3. billyellis

    billyellis TS Enthusiast Topic Starter Posts: 180

    Craptastic. :(

    I know nothing about Java. Is there any way to selectively disable certain Java applications like this without causing other problems??
     
  4. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    selectively ?

    You know I don't know :confused: And I don't say that, much

    I might need to find out a lot more about this new function (in both IE and Firefox, and possibly others)
    Anyway, I thought it was a good new function of Google (I suppose not eveyone feels the same) Even Mobile phones do this when you SMS (although that's just a local dictionary of words)

    Hmm :rolleyes:
     
  5. billyellis

    billyellis TS Enthusiast Topic Starter Posts: 180

    I understand that many people like it, and it makes sense when browsing with small devices where reducing the number of keystokes required is a plus. But for a computer I don't like it at all. Frankly I find it insulting to have software trying to finish my words for me like I am incapable of doing it myself.

    To each his own...but FF should not be forcing this feature on people who don't want it. There should be an option to disable this default functionality in the preferences, but there is not. :suspiciou
     
  6. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    I believe all OS will be online one day
    There will be no need for local HardDrive or even saving locally, this will happen when Internet speed increases 10 fold

    Therefore there will be no user settings to adjust !
     
  7. captaincranky

    captaincranky TechSpot Addict Posts: 11,055   +970

    I am running FF2 and it doesn't auto-complete web search type-ins. or (!) or (?). That's pretty much a take your pick on the punctuation.

    I could either swear I saw a setting to get it not to auto-complete, but I don't remember where or when. You could try installing "No Script", just for an experiment.

    OR, under "Tools" > "Options" > "Privacy" tab, then > "History", simply uncheck, "remember what I've typed in forms and the search bar". That ought to do it. Or undo it from doing it, if you prefer.

    Edit; Oh, now I remember.
     
  8. captaincranky

    captaincranky TechSpot Addict Posts: 11,055   +970

    Um, "about:config" what?

    Is there some reason that you think this doesn't work?
     
  9. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    I have reported this member Don Frag
    Please disregard his posts, hopefully Mods will remove all of them
     
  10. billyellis

    billyellis TS Enthusiast Topic Starter Posts: 180

    i.) it's not autocomplete that is the issue, but the pop-up selection box of suggested completions to your partial entry
    ii.) I have had NoScript for as long as I have had FF, so that is not a solution unfortunately
    iii) the forms memory is already unchecked.

    As for the address bar redirecting, I found the solution here:
    http://www.brainonfire.net/2006/09/01/turn-off-domain-guessing-and-keyword-search-in-firefox/
    after getting a partial solution at another board. It requires setting both
    browser.fixup.alternate.enabled
    and
    keyword.enabled
    to false.

    Now I just need to know why I am still getting the search box suggestions even though browser.search.suggest.enabled is set to false...
     
  11. captaincranky

    captaincranky TechSpot Addict Posts: 11,055   +970

    It is possible for the "about:config" files to become corrupted in Firefox.

    I had a problem with images not being loaded at one time. A "1" became a "3" for no apparent reason. Change back, issue solved.

    I can assure you that in my installation, changing the setting I suggested brings about the desired change, with no further action required.

    It might be worth it to try a complete uninstall and reinstall of FF. Just export your bookmarks to a safe place, uninstall the program, and then go into C:/ program files and throw away the entire "Mozilla" folder, Then download a fresh copy and start over.

    This is a longshot- slash- wild guess, but you might want to scan for malware. It occurs to me that a keylogger could cause this, but I'm not certain why I even think that. As I said, a wild guess. Well, the original function seems like it could be based in a keylogger.
     
     
  12. billyellis

    billyellis TS Enthusiast Topic Starter Posts: 180

    Update: I went ahead and uninstalled FF and upgraded to FF3 (for other reasons) and now browser.search.suggest is disabled and actually is turned off. Yay.

    Thanks to everyone for their input and advice.
     
  13. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Thanks for the update :grinthumb
     
  14. nantucket29

    nantucket29 TS Rookie

    I didn't see anyone else mention the keyword.enabled setting. If set to false via about:config, automatic searching from the address bar is disabled and Firefox shows an alert box when you have a typo in the URL.

    References (had to remove prefixes to post...sorry)
    kb.mozillazine.org/Keyword.enabled
    http://support.mozilla.com/en-US/kb/Location bar search

    Hopefully this is helpful to someone.

    Mod Edit:
    Provided exact helpful link in post
    .
     
  15. billyellis

    billyellis TS Enthusiast Topic Starter Posts: 180

    Thanks for the post nantucket29. I actually tried that at the time and unfortunately it did not work on the old version of FF that I had at the time. Don't know why exactly, but I think there was another component that was still active that could not be accessed by any of the default config settings. And since I did not feel confident enough to start adding my own, I gave up and updated to a newer version, despite the fact that I lost a couple add-ons that I liked in the process. Even the mighty FF has flaws on occasion. :)
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.