TechSpot

Firewall / RDP

By Cristy_m
Feb 22, 2011
Post New Reply
  1. I have tried everything to figure out why I can't get any RDP connection. I can connect remotely within my network so I know it is not an RDP setting. I believe that I have forwarded the port and opened the firewall but I still instantly time out when trying to get in through the net. I am using XP and D-link DI-624 router. my settings are listed. Am I just missing something?
     
  2. jobeard

    jobeard TS Ambassador Posts: 9,322   +622

    the firewall settings should be

    allow TCP IN/OUT port 3389​
    and then you need to port forward port 3389 to your PC address

    which must be a static address or a DHCP reserved address.
     
  3. Cristy_m

    Cristy_m TS Rookie Topic Starter Posts: 46

    Have I not done the allow? I posted a screen shot.
     
  4. Cristy_m

    Cristy_m TS Rookie Topic Starter Posts: 46

    And I know my DHCP is reserved.
     
  5. jobeard

    jobeard TS Ambassador Posts: 9,322   +622

    the screen shot does not show - - -

    which firewall are you using; the Windows default or some 3rd party?
     
  6. Cristy_m

    Cristy_m TS Rookie Topic Starter Posts: 46

    Third party software with D-link DI-624
     
  7. jobeard

    jobeard TS Ambassador Posts: 9,322   +622

    that's the router and only needs the port forward as noted.

    get a command prompt and enter runas /user:administrator control
    enter the admin pwd and
    scroll down to Windows Firewall
    a) it should be (*) On but [ ] Don't allow exceptions should be empty
    Click the Exceptions Tab
    b) find Remote Assistance and [x] enable it.​
     
  8. tipstir

    tipstir TS Ambassador Posts: 2,393   +107

    Make sure Assistant Remote is disabled. What happens when you run RDP do you get an error message? If so what does it say?
     
  9. Cristy_m

    Cristy_m TS Rookie Topic Starter Posts: 46

    I do get the basic error on my machine when I try no desktop connect. See JPG. When I try on my phone I get can not connect to (my IP) port 3389.
     

    Attached Files:

  10. jobeard

    jobeard TS Ambassador Posts: 9,322   +622

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...