First build motherboard installation issues

By Flash19
Feb 25, 2009
Topic Status:
Not open for further replies.
  1. OK guys bear (bare?) with me on this one. I got my new case the other day and I want to install my mobo. The case has a detachable plate to put it it on, and it looks like this (be warned - big images)


    On the right hand side it has six of these, two you can't see in the first picture.

    Then it has three of these on the left hand side.

    Now my case instructions say to line the mobo holes up with the case holes, which seems obvious but doesn't mention screwing anything in. But if I don't then the thing will just drop off as soon as I lift my case up. As you can tell I'm at a loss really with what to do and I could use any help, at all. There is a gap for the IO shield in the case so I know which way the board should be oriented, but I don't see how I can screw anything into the holes on it when there are those other bits (from the case plate) coming through them. My motherboard is ATX and my case is ATX or mATX compatible.

    - Apologies for the poor picture quality.

    Thanks.
  2. mailpup

    mailpup TS Special Forces Posts: 8,414   +215

    Don't you just "pop" those standoffs into the motherboard holes?
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.