Flash drive not registering on one computer, but does on another

By zoey780
Dec 29, 2010
Post New Reply
  1. HELP! I am trying to put documents/music/photos on my flash drive, so I can transfer them to my new laptop. When I try and drop documents onto the flash drive it tells me the drive does not have enough free space. It has plenty of space and works just fine on my new computer. It has always worked on my old computer, so I don't know what to do. Any input would be appreciated. Thank You.
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

  3. zoey780

    zoey780 TS Rookie Topic Starter

    Thank You

    I cleanup ed the usb drive as well as the computer and ran a repair application as well. It worked!!! I guess my Mac just had a little cold and just needed some love. Thank you
  4. CamaroMullet

    CamaroMullet TS Rookie Posts: 93

    Is the thumb drive formatting Fat32? Fat32 has an individual file size limit of something like 4gigs. If you are trying to copy something larger then 4gb you can get that error.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...