TechSpot

FPS on Gigabyte Radeon 9600 Pro

By lolka999
Nov 12, 2009
Topic Status:
Not open for further replies.
  1. Hi all! :) I realy hope you can help me! :)

    Few days ago, I bought graphic card (Gigabyte Radeon 9600 pro), I hoped that I finally can normally play Counter - strike, but no ;( I have realy bad fps drops :(( When I play shooting maps, it`s not so bad (but I don`t like that either), but when I play HNS maps, it`s just drawing me crazy! :mad:


    My PC:

    CPU - AMD Sempron 2300+
    RAM - 512
    Power Supply - 350w (I think so)

    With my CS configs all fine, vsync off...

    I don`t have more ideas...:(

    The funiest thing is, when I got old graphic card (Nvidia mx 400), my fps was fine (sometimes small fps drops), but this graphic card (who have to be better) - is like ****...:(

    p.s.

    Sorry about my english (if I have mistakes) ;)
     
  2. red1776

    red1776 Omnipotent Ruler of the Universe Posts: 5,897   +88

    lolka,
    you have a number of things working against you here. first you are dealing with two cards that are 8 and 6 years old respectively, they just dont have the horsepower to play any thing newer. secondly you have a single core processor, and not a very powerful one at that. thirdly, 512 of ram is barely enough to run the OS much less tax it with something as intensive and resource demanding as gaming. i imagine you were playing low detail at a very small res?
     
  3. lolka999

    lolka999 TS Rookie Topic Starter

    I know I have cute old PC, but how I wrote, when I had old graphic card, all was fine, but soon I bought this one, I have this fps drops ;(

    Only game what I`am playing is Counter-Strike, other games I don`t need ;) But now, I can`t even play counter-strike ;(

    Suggestions?
     
  4. mailpup

    mailpup TS Special Forces Posts: 8,442   +220

    Did you uninstall the old Nvidia graphics driver through Add and Remove Programs before installing the ATI driver. What version ATI driver did you download and install?
     
  5. lolka999

    lolka999 TS Rookie Topic Starter

    No, I didn`t uninstall the old nvidia driver, why I have to? If I don`t have nvidia card more? :) You think it`s may cause this problem? :))

    Now I`am at work, when I`ll be home, I try uninstall nvidia driver, hope it helps! :)
     
  6. mailpup

    mailpup TS Special Forces Posts: 8,442   +220

    You should always uninstall the old graphics driver to avoid possible conflicts. You didn't say what ATI driver you installed.
     
  7. lolka999

    lolka999 TS Rookie Topic Starter

    Ok, now I will know that :)

    I have installed latest driver for my graphic card, taken from official ATI drivers homepage!

    But nothing changes :(
     
  8. mailpup

    mailpup TS Special Forces Posts: 8,442   +220

    Did you install Catalyst version 9.8? Driver only or full Catalyst suite?
     
  9. lolka999

    lolka999 TS Rookie Topic Starter

    Full Catalyst suite
     
  10. lolka999

    lolka999 TS Rookie Topic Starter

    Problem solved! :) Thanks all for help :)
     
  11. mailpup

    mailpup TS Special Forces Posts: 8,442   +220

    Great! How did you solve it?
     
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.