Game runs too fast!

By Doctor Gallop
Oct 22, 2006
Topic Status:
Not open for further replies.
  1. I dug out an old favorite PC game of mine called 'Outlaws" and thought I would try to play it again. Have not played it in years, when I was still running Windows '98.
    But now that I have Windows XP I notice that the same game runs too fast.
    Can someone explain why that is?
    I installed the game the same as I use to. Can it be ajusted?

    Thank you.

    Dennis
  2. Ollie30001

    Ollie30001 Newcomer, in training Posts: 170

    Hmmmm, cant help ya soz, but the same thing is happening to me, but with newer games, Flatout and painkiller (ok not that new)

    thinking its got something to do with duel core cpus for some reason.....


    anyone?
  3. TimeParadoX

    TimeParadoX Newcomer, in training Posts: 2,438

    Isnt it a good thing for it to run fast? =P
  4. Ollie30001

    Ollie30001 Newcomer, in training Posts: 170

    Yeah, but not this fast!!!

    its i super kind of fast, like all the movies and that before the game starts are like sped RIGHT UP, everything is fast, and it usually causes the game to crash after a while

    it is fun tho, running around on painkiller REALLY fast, as it is a fairly fast game any way
  5. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +17

    You could try using CPUKiller to slow your computer down when playing old games that run too fast.

    There is also a programme called Mo`Slo that`s supposed to be very good. However, it`s only a trial programme and has to be purchased once the trial has ended.

    Regards Howard :)
  6. wolfram

    wolfram TechSpot Paladin Posts: 2,605   +9

    Are you using an AMD CPU? If so, are you using Cool & Quiet technology? Or an Intel CPU with a similar power saving technology?

    I normally have it enabled, but if I start a game, it will run too fast. Then I disable it, and it runs normal.

    Regards :wave:
  7. Didou

    Didou Bowtie extraordinair! Posts: 5,899

    It is either a CPU-clock throttling feature giving that problem or maybe the fact that you have a dual-core or HyperThreading enabled CPU. If the latter is the case, when you launch the game, ALT-TAB back to the dekstop, launch the task manager, right click on the game's process & set CPU affinity to one CPU.
  8. skitzo_zac

    skitzo_zac TechSpot Chancellor Posts: 459

    I wish my computer wasnt so lame that i could have that kinda problem!
  9. miked8887

    miked8887 Newcomer, in training

    Descent - too fast

    I know this question is redundant, but I just downloaded Descent (3D space shooting game), and it runs, again, too fast. Does anybody know of a solution for it? Is there even hope?

    Thanx...
  10. Didou

    Didou Bowtie extraordinair! Posts: 5,899

    Have you tried alt-tabbing out of the game & setting the affinity to only one CPU core ? That's if you're running a dual core system at least.
  11. pcnthuziast

    pcnthuziast Newcomer, in training Posts: 313

    He shouldn't have to do that, it's a work around vs. a real solution.
  12. Didou

    Didou Bowtie extraordinair! Posts: 5,899

    Well in certain cases there are no real solutions. Games that are too old & that will not be updated will always have that problems. If he still wants to play the game, that's how he should do it (if it is indeed the problem that he's having now).

    I know that AMD have released a dual-core optimizer but I'm not sure if it stops the problem of games running too fast on systems with multiple cores/CPUs.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.