Games going too fast

By basjehode
Nov 29, 2005
Topic Status:
Not open for further replies.
  1. What can you do when a PC-game is going too fast?
    Someone probably knows what I'm talking about. It's a 1.st person view game so walking, converstions and enemies are all going too fast. As if the computer is too good or something. The name of the game is Deus Ex.
    Could anyone help me out?
  2. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    Hello and welcome to Techspot.

    Go HERE and download the Cpukiller programme. It will enable you to slow your computer down in order to play older games. When you have finished playing, just close the programme, and your computer will return to normal.

    Regards Howard :wave: :wave:
  3. LNCPapa

    LNCPapa TS Special Forces Posts: 4,288   +262

    Must be one hell of a computer to make Deus Ex go too fast. Isn't that one of the most inefficient engines of all time?
  4. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    Hey LNCPapa.

    Can`t you tell that I don`t play games lol.

    Regards Howard ;)
  5. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    This doesn't sound like a problem to me! ;)
  6. JimShady23

    JimShady23 TechSpot Maniac Posts: 651

    LoL

    I thought that id never hear the words "My computer is running a game too fast!!"

    Probably never here that from them doom 3 and quake 4 addicts....

    And since i mentioned quake 4, did they really live up to the hype of it beginning where doom 3 left off as fare as map detail, not all dark and stuff..

    Thinking of buying it for a early x-mas pres to myself......let me know
  7. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    Of course another way to slow down a computer is simply to install Symantec/Norton. works like a charm :p

    Regards Howard :)
  8. smtkr

    smtkr Newcomer, in training Posts: 138

    You are using a laptop with Speedstep. Go into your power profile and turn it to desktop.

    EDIT: Turn it to "Home/Office Desk"
  9. basjehode

    basjehode Newcomer, in training Topic Starter

    doesn't work...

    It doesn't seem to work as well as I hoped it would, this desktop/home thing.
    At first the game was working properly, but then it suddenly went slower than it was supposed to. So "laptop" is too fast and "home" is too slow.
    And I haven't been able to find something in between either.
  10. smtkr

    smtkr Newcomer, in training Posts: 138

    Can you be a little more specific?

    For example, the game started off running normally. When you say it began to run slowly, are you talking about a frame rate dip, or something exactly opposite to the "too fast" problem?

    Maybe try turning speedstep off in the BIOS?


    EDIT: Also, try a setting called "Always On" in the power profiles.
  11. basjehode

    basjehode Newcomer, in training Topic Starter

    Not a frame rate rip no, I think that's what occured when i ran the cpukiller program. When I turned the power profile to "home/work" settings, the whole game went slower, as in perfect slow motion. But for about 20-30 seconds at a time the game goes at a normal speed, and then turns back to slow.

    Also, I'm not sure I know what you mean by turning speedstep off in the BIOS... the language on my computer is norwegian and... my english is not what it oozed to be.
    So where may I change the BIOS?
     
  12. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    The BIOS should still be in English unless you have some OEM machine. And you can always flash the BIOS to an English version :p
  13. smtkr

    smtkr Newcomer, in training Posts: 138

    I think this is beyond the scope of my knowledge. I had this exact problem with Deus Ex when I first played it on my Pentium 4-M 3.06GHz laptop. I solved the problem by changing the power profile to Always ON or Home/Office Desktop (I can't remember which). I don't think I had to change anything in the BIOS.

    Sorry.
  14. basjehode

    basjehode Newcomer, in training Topic Starter

    feels like I'm getting close

    I managed to acces the BIOS and they were in english. But I was not able to see anything called speedstep. By turning the power profile to "Always on" or "alltid på" as it's called in norwegian, the game ran almost perfectly, except for a few moments of slow motion.
    And thanks for all the help by the way, smtkr.
  15. meNOname

    meNOname Newcomer, in training Posts: 122

    running to fast??
    what? huh? come again? i cant hear you?

    wish my computer would run to fast..even if i had to type shoot and run around at the same time...i will gladly take your "too fast" computer from you?
    :)
  16. Row1

    Row1 TechSpot Maniac Posts: 355   +8

    "turbo" button

    running too fast - that's why comps used to have a "turbo" button. before the home comp got really common, visual and game programs were not written to run at a certain speed; as comps got faster, the visual part also got faster - so you would hit the "turbo" button off to make the comp run slower. When you were done, you would hit the turbo back on.

    this worked on some dos stuff and even some games in win3.1.
  17. lithiumdeuterid

    lithiumdeuterid Newcomer, in training Posts: 91

    This turbo button concept sounds like utter rubbish to me. Before home computers (such as the Apple IIe), I find it hard to imagine anything running so quickly that people needed to slow it down. Plus, what the hell is this turbo button connected to?

    If the game is worth anything, it will have a framerate limiter built in. Check all the menus for such an item. If it does not have this, then the programmers were slacking, and you're screwed.
  18. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    Regards Howard :)
  19. Ruder

    Ruder Newcomer, in training Posts: 134

    I have the same problem ... PC is running too fast. Games are unplayable - GTA SA, NFS MW, etc ...
  20. LNCPapa

    LNCPapa TS Special Forces Posts: 4,288   +262

    I had 2 machines in the past that had turbo buttons on them :) Just old technology. Many old games didn't have any kind of framerate limiters on them - it's a fact of life that won't be changed anytime soon - hence the need for cpukillers and other slowdown apps.
  21. Druegan

    Druegan Newcomer, in training Posts: 26

    I have the exact same problem..

    I just built this machine not but 2 weeks ago...

    AMD 64 X2 4800+ processor
    1 GB Mushkin XP3200 Dual Channel DDR ram
    DFI LanParty UT nF4 SLI-DR mobo
    eVGA GeForce 6800 XT PCI Express 256MB vid card
    Creative Labs SBLive! 24-bit sound card
    Western Digital Raptor 10k rpm SATA 74 gig system drive
    and a terabyte of additional data storage, not that it really matters.

    Running Windows XP pro SP1.

    All drivers should be up to date, as I went and downloaded the newest versions when I built it.

    Problem is, GTA: Vice City AND GTA: San Andreas are running WAY too fast. Almost completely unplayable. To the degree that the main character looks almost like a blur when running. Driving is impossible.. touch the gas and I'm halfway across the city or in a collision.

    Nothing is overclocked, everything running at default. Any ideas?
  22. Vigilante

    Vigilante TechSpot Paladin Posts: 2,120

    For an old game, it's best to play it inside an "emulator" that will trick the game into thinking it is running on old hardware. XP has this built-in when you right-click on a shortcut and go to the "Compatability" tab. If you make a few selections in here and play with it, you may be able to slow yourself down.

    Otherwise, I don't know offhand of any good emulators, because I haven't done this in years. But do some searching and you'll find something.

    Ahh, the turbo button, how I miss thee....

    I've got this problem, Half Life 2 and Battlefield2 run WAY to fast, I mean, I have like 600 fps............NOT! Won't it be nice when, 10 years from now, we'll still be complaining about this problem, with todays biggest games?
  23. Druegan

    Druegan Newcomer, in training Posts: 26

    Yeah, I played with a few emulators years ago. Problem is, neither Vice City or San Andreas are really "old games".

    I also tried loading down the system with a program called "CPU Killer" that somebody (I think twas howard_hopkinso) recommended on another thread.

    I ramped the system load up to 50%, and yes, the game slowed down.. But one quirk I noticed was that while the game itself slowed due to system lag, the speed elements in the game were still running far faster than they should have been. I dont' know quite how to describe it better than that. Unless it helps to describe it as "Like running in fast forward but with lag."

    Perhaps I'll borrow some of the roommates games to test and see if it's just Rockstar's products, or everything. Twould suck if I can't use this beast because it's too fast for games.
  24. Didou

    Didou Bowtie extraordinair! Posts: 5,899

    Launch the game, then ALT-TAB back to the desktop & launch the task manager (CTRL+SHIFT+ESC). Find the game's process in the process tab, then right click on it & select processor affinity. Untick one of the CPUs.
  25. Druegan

    Druegan Newcomer, in training Posts: 26

    Didou, that's BRILLIANT!

    Thanks much! I never would have even thought of that.
    It fixed the problem right up :)
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.