Gamtec PS to USB won't work

By unD!
Oct 23, 2006
  1. Hey everyone,

    A few years back I bought a Playstation to USB device that lets me plug my Playstation controllers into my computer so I can use them to play games.

    I recently got it off the shelf, and plugged it into my computer. The drivers automatically installed - though I downloaded them from the Gamtec website to be sure and installed them. It recognized the device, and said "USB Human Interface Device" or something like that. Anyway, I tested it on Counter Strike (Half Life 1 Version), with the 'Joystick' enabled - however, in the game the controller failed to work.

    I also tried changing the buttons (eg, fire, move forward) but they did not change to any of the PS controller buttons. So I'm stuck with the default settings (Spacebar - jump, mouse1 - fire, etc) and the PS controller fails to run. Keep in mind that I am using a controller from the Playstation 1, the one without the analog sticks.

    I had it working in the past with GTA Vice City. Could it be the game, damage to the device, or my sheer lack of knowledge about such things? Help would be greatly appreciated.
  2. Jesse_hz

    Jesse_hz TS Maniac Posts: 545

    You say that you installed the driver from the Gamtec webisite, have you tried using it with just the generic windows drivers?
  3. unD!

    unD! TS Rookie Topic Starter

    They automatically installed when I put the PS to USB device in. It said "Your hardware is installed and ready to use"
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...