Geforce 6800 BF2 Shader Problem

By Rodex
Aug 11, 2005
  1. Hmm so you may of seen my post for the solution to crashing to the desktop with a radeon 9200 playing bf2. Well good news i ditched that system and got an Alienware 51m laptop! Now it plays fine on settings maxed out, but the shadows are boxy and messed up, if i turn them off everyrthing is fine, but id like all my settings high, and im pretty sure that this system could handle it, anyone have a solution. I have downloaded the latest drivers from alienware, i just cant find a solution.

    Heres the specs

    P4 HT 3.0 ghz
    1gb of RAM
    80 gb HD
    Geforce 6800 256mb Go
  2. AtK SpAdE

    AtK SpAdE TechSpot Chancellor Posts: 1,495

    congrats on the new laptop, a nice improvement i must say.

    Im would first try the patch (1.02) it can be found here
  3. Rodex

    Rodex TS Rookie Topic Starter Posts: 29

    Thanks, yep it is a very nice improvment.

    Anyways that still doesnt work, are there any links for GeForce Go drivers, cause the regular ones do not work for my card
  4. chief barker

    chief barker TS Rookie Posts: 28

    The boxy shadows in BF2 are quite normal, there have been many posts on BF2 forums about the same issue.

    I have exactly the same thing with my 7800 gtx.

    Have you made several adjustments to your graphics settings for BF2?

    If you have, you may need to delete the shaders and let the game optimize these again to the graphics settings you are happy with.

    Start>my documents>battlefield 2>mods>bf2>cache then delete the files within this cache folder.

    Next time you you load a map the shaders will be optimised.

    Hope this helps , good luck
  5. Rodex

    Rodex TS Rookie Topic Starter Posts: 29

    I had to download the 77.77 forceware drivers from laptopvideos2go, everything works fine now!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...