Google Chrome causing in-game lag?

By ramonsterns
Jun 10, 2012
Post New Reply
  1. So, here's my problem.

    I have two monitors, usually one I'm watching a video, playing a game, writing a paper, whatever. The other usually has google chrome open, so I can browse the internet while waiting for a friend or looking something up relevant to what I am doing.

    Everything is fine and dandy until suddenly, I start lagging. My ping is usually around 100 to 120 in the game I'm playing, then it will spike to 200 a couple of times and sometimes stick around 500 or more.

    So I start to wonder, is it the game? Is it the connection in general? Is it something I'm running in the background? I open up task manager and my resource monitor, lo and behold, Chrome is busy eating my bandwidth for no apparent reason. I exit Chrome, and the lag is gone.

    Any ideas what's up? Is it Chrome? Do all browsers suddenly decide to deprive their users of their connection whenever they feel like it?

    Help me, please.
  2. learninmypc

    learninmypc TechSpot Guru Posts: 4,583   +186

    How many if any addons do you have on Google Chrome?
    Have you tried duplicating this situation with your other browsers?
    Unless I missed it, how much RAM do you have installed ? You can go to www.crucial.com to find out.
    This won't help me help you,but it might help someone here help you.
  3. ramonsterns

    ramonsterns TechSpot Enthusiast Topic Starter Posts: 752   +12

    I currently have AdBlock, FlashBlock, and DiVX HiQ active.
    Not sure how, it just sort of comes and goes I'd have to have another browser open at both times.
    I have 4gb of RAM.
  4. Blkfx1

    Blkfx1 TechSpot Addict Posts: 866   +167

    I would advise just trying a different browser entirely. I have read on multiple occasions that Google Chrome likes to suck large amounts of bandwidth randomly.
  5. DevilDevansh

    DevilDevansh TechSpot Member Posts: 53

    Possibly your Adblock and FlashBlock.
    Google Chrome will ocassionaly do that with me too so I tried Internet Explorer 9(All addons disabled), working okay .
    **A week ago it denied me as rightful user and stopped saving preferences. Now its okay, though some times it denies me my rights.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.