TechSpot

GPU dead? Displays picture only

By XSpike
Jul 8, 2011
Post New Reply
  1. I'm currently having a hardware fault, happened awhile ago now but I can afford a new GPU now if I have to but thought I'd futher investergate whats going on. So thought I'd ask for some help.

    Turned PC on one day, got the blue screen booted into safe mode tried a few things forgot how I found out but I disabled my display drivers and then my PC was able to boot up without safe mode. Since then all my PC does is watch movies, surf the net and just the basic stuff.

    So my GPU is still sending a video signal but if I enable the device, my PC either gets a blue screen or hangs on a black screen after loading windows vista

    The card I was running is a geforce 9800GTX-2 in yes my PSU is powerful enough
     
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    "So my GPU is still sending a video signal but if I enable the device"...

    Graphics cards... or anything else in a computer need drivers to function. Download and install the proper drivers for your GeForce card here:
    Nvidia 9800GTX-2
     
  3. XSpike

    XSpike TS Rookie Topic Starter

    Have tried this before, Tried it again anyways, uninstalled my old drivers and what not installed the new one and still the same problem after its finished loading windows vista it just goes to a black screen. Restarted in safemode and had to disable the drivers for PC to start up 'normally'
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...