TechSpot

GPU won't run in new rig

By Reystar
Oct 21, 2012
Post New Reply
  1. Reystar

    Reystar TS Rookie Topic Starter Posts: 25

    Got my new stuff!
    GTX 670 and a Corsair 850W
    Also I added 8 more gigs ram!

    Though I'm not sure why CPUID doesn't display the Memory of the card:
    [​IMG]

    Shouldn't there say 2GB Size and DDR5? Under memory
     
  2. JC713

    JC713 TS Evangelist Posts: 7,080   +920

    there is something wrong here... I have my memory listed. try gpuz, it is better for GPUs
     
  3. JC713

    JC713 TS Evangelist Posts: 7,080   +920

    is the issue fixed now?
     
  4. Reystar

    Reystar TS Rookie Topic Starter Posts: 25

    [​IMG]

    There you go...hmm what's up with CPUID? lol :S
     
  5. JC713

    JC713 TS Evangelist Posts: 7,080   +920

    did u upgrade to 306 drivers? make sure you clean install them
     
  6. Reystar

    Reystar TS Rookie Topic Starter Posts: 25

    Yeap, 306.97 clean installation...
     
  7. JC713

    JC713 TS Evangelist Posts: 7,080   +920

    Are the issues gone?
     
  8. Reystar

    Reystar TS Rookie Topic Starter Posts: 25

    On CPUID nope, maybe it does not recognize the latest tech or something...cause GPUZ works just fine from what I see :S
     
  9. JC713

    JC713 TS Evangelist Posts: 7,080   +920

    cpu z is mainly for cpus, it is not great for gpus, it is meant for detailed cpu info and vague gpu info. is the issue gone though? the cpuz issue is no problem just a glitch
     
  10. Reystar

    Reystar TS Rookie Topic Starter Posts: 25

    In which problem you referring then? :D
     
  11. JC713

    JC713 TS Evangelist Posts: 7,080   +920

    the first one you said
     
     
  12. Reystar

    Reystar TS Rookie Topic Starter Posts: 25

    I returned the GTX660 and I bought the 670!
     
  13. JC713

    JC713 TS Evangelist Posts: 7,080   +920

    but did it fix the gpu issue of it not working?? so the 670 is stable
     
  14. Reystar

    Reystar TS Rookie Topic Starter Posts: 25

    Yeap the 670 is stable :)
     
  15. JC713

    JC713 TS Evangelist Posts: 7,080   +920

    Cool good stuff
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.