TechSpot

Graphics card overheating?

By Jsreese
Apr 1, 2012
Post New Reply
  1. Alright guys, I need some help with something. I currently game on an Alienware m17x laptop. I have an ATI Mobility Radeon HD 4870 in the laptop for my graphics card. I had some problems with one before where it would overheat and my computer would shut down, I am guessing it did this as a safeguard. Well, I got a new one, and normal games like WoW or The Old Republic work fine on it... but when it comes to something like Skyrim, my computer will shut down after about 10 minutes of play time. I assume this is because of overheating. I have a cooling pad under my laptop and I have a box fan sitting behind the laptop blowing cold air straight into the vents. I added the box fan today when I became frustrated with it crashing repeatedly. I am in a room that is regular temperature, not too hot or too cold, but it still crashes. Is there a way I could make it where my graphics card would not run as hard as it does to reduce the amount of heat it produces? Any advice would be great.
     
  2. EXCellR8

    EXCellR8 The Conservative Posts: 2,278

    yep, this is one of the most common problems with gaming on laptops. obviously there is less airflow inside of a laptop vs a desktop so unfortunately it can be tough to control temps. my best advice would be to make sure the fan duct(s) are clear and that the fan itself is working properly. those higher end mobile GPUs can get pretty hot, especially with more demanding games which require them to work harder etc.

    if you find that nothing helps the crashing, it may be a good idea to abandon the most demanding titles and use a desktop instead.
     
  3. TekGun

    TekGun TS Enthusiast Posts: 160   +15

    If you have the Catalyst Control Centre from ATI installed, just go to the tabs on the left; Performance > AMD Overdrive, then check "Enable Overdrive" and set your GPU Clock/Memory Clock slightly lower than stock, then test.
    Also you might want to try this first, in the same place check the box for "Manual Fan Control" and set it as high as you can whilst still at an acceptable fan noise. You might find that the auto fan mode was just not running high enough.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.