Hard disk capacity

By Kserijaro
Apr 1, 2009
  1. Hello, again.This time I am asking for an advice.I went to my friend's house to set up a new hard disk and to make a fresh installation of windows XP SP2.So...We failed to take out the old hard disk.The new one is western digital SATA,proclaimed for 640 GB.Anyway.we pulled out the plug from the old one and put them in the new one.Windows installation started and I was asked how to format the hard drive.The maximum that was available was 130GB.But I haven't tried to manually raise the number,considering the whole capacity would be shown.So, after it has finished, entering the drive shown only 128 GB(loss on Xp installation.)So.Later we tried to format the drive suing partition magic.I haven't stayed 'till the ending of the formatting.But he accidenta typed 500MB instead of 5000MB. The problem that I have is...visiting hard drive information from BIOS has showed me that PC recognizes the full capacity of the drive (inside the [640GB]).How can I delete the previous installation and format the drive to ~640Gb correctly?
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,185   +225

    Just start the Windows install once more. When the install gets to "previous installations", delete the existing partitions and format to the full capacity of the drive. Continue installing Windows
  3. Kserijaro

    Kserijaro TS Rookie Topic Starter Posts: 57

    Hmm...i will try that very soon.Help for the tip!I will report the end of this tragedy :p as soon as I reach it.
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,675   +389

    If you saw a max of somewhere around 130GB during the XP install it is because you have XP prior to any service packs. You'll want to partition/format the drive with a 3rd party tool first, OR create a slipstreamed XPSP3 disk.
  5. akashaheart

    akashaheart TS Rookie

    i know at one time on my older pc i went ahead and let it go thru install with the gb it saw and after install I went under control panel-admin tools-computer management-storage and made the rest available shows up as another partition.
  6. tuant

    tuant TS Enthusiast Posts: 200

    Make sure your BIOS supports 48-bit LBA. If not try flashing your BIOS with the latest patch. After that you can edit your registry in XP to enable 48-bit LBA for large hard drives.

    Click Start, then Run and type REGEDIT and click OK

    Go to the following path: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Atapi\Parameters\

    Next set the EnableBigLba registry value to 1 in that registry key. Exit Regedit and reboot.
Topic Status:
Not open for further replies.

Similar Topics

Create an account or login to comment

You need to be a member in order to leave a comment
TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...

Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.