Having Trouble with windows update, and spywares

By vires90
Mar 29, 2009
  1. I had a Malware defender 2009 problem.. so i ran malware bytes and removed it.... but now when i click on windows update it shows me an error and i am unable to do so.. please help

    Attached Files:

  2. touch

    touch TS Rookie Posts: 978

    Hello vires90

    You have a large number of infection, I´ll therefore suggest you proceed as follows ->

    I notice that you do not seem to be running antivirus software.This is somewhat suicidal in today's digital world.

    Avast makes an excellent free antivirus client
    As does

    Install Avast or Avira. Update it, run a complete systemscan, have it to fix/quarantine what it find.


    Then please run the steps in this guide:

    8-step Viruses/Spyware/Malware Preliminary Removal Instructions

    Post attached log´s from:


    In your next reply
  3. vires90

    vires90 TS Rookie Topic Starter

    hey, well installed the avg.. n ran the can.. but when i restarted my window... it loads and the it gets stuck i cant click on any icon or anything.. so i was thinking about running it on safe mode.. let me know should i
  4. touch

    touch TS Rookie Posts: 978

    Yes, please run it from safe mode with network
  5. vires90

    vires90 TS Rookie Topic Starter

    ok i ran it... and then i did a pc restore.. and then i ran malware bytes.. and the avast thing.. n deleted some of the infected item.. however i deleted avast cause its running very slow on my comp... attach is a new hijack this log and malwarebyte log
  6. touch

    touch TS Rookie Posts: 978


    It is possible you´ll have to do the below from safe mode with network. However, try from normal mode first

    Please download Combofix:

    And save to the desktop. -<< Save it as mike.exe

    Close all other browser windows.

    Please connect all your external hard drive/flash drive before running Combofix, if you have any

    Double-click on the combofix icon found on your desktop.

    Please note, that once you start combofix you should not click anywhere on the combofix window as it can cause the program to stall. In fact, when combofix is running, do not touch your computer at all and just take a break as it may take a while for it to complete.

    When finished, it will produce a logfile located at C:\combofix.txt.

    Install Avira:

    Attach the contents of combofix.txt in your next reply, along with fresh hijackthis log
  7. vires90

    vires90 TS Rookie Topic Starter

    OK i have done the combo fix.. now i am install the avira..
  8. touch

    touch TS Rookie Posts: 978

    Sounds good :)

    Uninstall this folder:
    c:\documents and settings\Nida Iqbal\Application Data\FrostWire

    Please tell how your computer are behaving, after you have scanned with Avira ?
  9. vires90

    vires90 TS Rookie Topic Starter

    yea the other computer is ok... can you check what is wrong with this one.. its running kind of slow
  10. touch

    touch TS Rookie Posts: 978

    There are some leftovers in the hijackthis log. Before we remove them, please tell, have you edit your Hosts file ?
    O1 - Hosts: S

    Is it a Trial version of McAfee you have installed ?
  11. vires90

    vires90 TS Rookie Topic Starter

    i dont know what host files are?
    no its a full version.. subscription for 3 years
  12. touch

    touch TS Rookie Posts: 978

    Ok :rolleyes:

    Run a scan in HijackThis. Check each of the following and hit 'Fix checked' (after checking them) if they still exist (make sure not to miss any):

    R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page =
    R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page =
    R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant =
    R0 - HKLM\Software\Microsoft\Internet Explorer\Search,CustomizeSearch =
    O1 - Hosts: S
    O2 - BHO: (no name) - {02478D38-C3F9-4efb-9B51-7695ECA05670} - (no file)
    O2 - BHO: (no name) - {5C255C8A-E604-49b4-9D64-90988571CECB} - (no file)

    Reboot. Attach new hijackthis log, and tell how things are running now ?
  13. vires90

    vires90 TS Rookie Topic Starter

    it gave me an error when i ran hijack this.. something about overwirte host file.. so i ran is as administrator
  14. touch

    touch TS Rookie Posts: 978

    Ok. Hijackthis log looks clean - How are your computer behaving ?
  15. vires90

    vires90 TS Rookie Topic Starter

    for some reason its running very slow.. like its not smooth like it used to be before.. u know what i am saying.. like when i watch videos n stuff it gets stuck n then resumes.. dont know what to do please help
  16. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    I'll tell the truth :)

    It's because you're running horrible McAfee . I say horrible because most times it misses Viruses (how absurd is that) Anyway here's what I'd definitely do.

    Uninstall your McAfee Antivirus
    Then run the McAfee Removal Tool


    Install Avira free AntiVirus
    Confirm it's all updated (I usually right click on the tray icon and then select "Start Update")
    Then run a full scan.

    Reply back with you shocked surprise of what it found ;) (oh and automatically removed)
  17. vires90

    vires90 TS Rookie Topic Starter

    ok ill try that and let you know.. . but damn i just bought mcafee subscription
  18. vires90

    vires90 TS Rookie Topic Starter

    hey, its running much smoother but.... but as i turn on my computer the.. start up items take time to load..let me know thanks
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...