HD 5770 no output

By BigBen007
Mar 12, 2013
Post New Reply
  1. Hi guys I have an issue with the above mentioned graphics card,
    my system,

    Cmx45 mobo, Intel core 2 duo cpu, winpower 550W power supply,
    3GB ddr2 800MHz ram, 2 x 500GB 1 x 1TB Hard Drives, x-fi extreme audio.

    I had a gts450 card in, worked perfectly. Now I tried my HD5770
    and there's no display. When I plug the 6 pin power lead in the 5770
    the fan runs, but when it's not plugged in the fan runs louder/faster, what's up with that?

    Anyway when the 5770 is plugged in and I boot up I get one beep, so all good.
    I haven't tried vga yet, only hdmi.
    I just want to know (at this point) Could it be my power supply?

    Thank you for taking the time to read this.

    Any suggestions?
  2. DonNagual

    DonNagual TechSpot Ambassador Posts: 3,565

    This is one of those 'shotgun' approach cases. You'll have to try a couple things.

    Best case scenario, you have a neighbor or friend close by with some parts you can swap / test to find what's working and what isn't.

    Other things to check. Update bios if it's an older one.
    Make sure you have the latest graphics driver.

    Possibly your PSU if it was a cheapy. What make/model is it?


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.