TechSpot

Help getting second sata drive recognised?

By 4doormonster
Jan 7, 2010
  1. Motherboard: gigabyte GA-EP43-UD3L

    i have installed windows 7 and it will not show the second hdd under my computer. it says in my bios that the drives are in channel 1 master and slave. my drive with windows 7 is master and the other with my files is in slave (in the bios, cmos setings)

    should i put the sata in AHCI mode or leave as ide also should i enable port 0-3 native mode?

    right now on the mobo my drives are hooked up like this:

    motherboard connections

    [sata2_3] sata2_0
    sata2_4 ^sata2_1^
    sata2_5 sata2_2

    ^xxxx^ is master [xxxx] is slave i hope this is clear enough

    thanks in advance im getting a bit confused
     
  2. captaincranky

    captaincranky TechSpot Addict Posts: 10,811   +921

    Have you formatted the SATA drive? Is that where tho OS is?

    A un-formatted HDD will NOT show in "My Computer", or "Computer" in Win 7.

    Disconnect the IDE drive altogether. Set the HDD detection mode of the board to auto.

    Win 7 will run a SATA drive as SATA natively.
    I think your board has an auto detect mode for the HDDs. Let me know if this isn't so.

    See, here's where I'm confused. If Windows can't detect the hard drive, then Windows can't be installed on it. Because if it was, Windows would have formatted it during the install. And it OBVIOUSLY would be detected.

    So, (at least given the context of your original post), of course the computer won't boot from the new drive, since it doesn't have an OS to boot from. Capesh?
     
  3. 4doormonster

    4doormonster TS Rookie Topic Starter

    Both drives are sata and the master drive has windows 7 on it and the other is formatted and full of files from my previous install (just upgraded to new mobo and processor) that diagram up above is the slots on my mobo, 2 of them are used. i also just tried booting it with the slave drive unplugged from the sata connector and it would not boot it wanted me to insert system disk right after it looked for a boot-able cd. i hope this is a little clearer
     
  4. mailpup

    mailpup TS Special Forces Posts: 8,452   +227

    If the SATA controllers are in IDE mode now, switching them to AHCI mode would require you to reinstall Windows, I believe. At least it was that way with XP. And under AHCI mode you would have to install SATA/RAID controller drivers during Windows installation (even with Windows 7, I think) or create a slipstream CD with the SATA drivers included to install the operating system.

    If you are going to leave it in IDE mode, you can enable port 0-3 native mode. If you don't like it, you can disable it again.
     
  5. captaincranky

    captaincranky TechSpot Addict Posts: 10,811   +921

    Is there another OS present? You keep posting that the system is booting from the wrong drive. And the new drive is not detected. So no, nothing is very clear.

    If as you say you replaced the motherboard, then you might have to reinstall Windows.

    If the motherboard is not detecting the drive, then you need to set the drive mode to whatever mode the board will recognize.

    If Windows is asking for the system disc, then the drive is in the wrong mode (IDE, ACHI, SATA) or the drive is not in the correct position in the boot sequence. Then you go into BIOS boot menu and move the drive you intend to boot from, to the first position.
    Oddly, I think that Windows 7 will run SATA as SATA natively. It does offer the option to install drivers, but I suspect that is only necessary if you intend to run the array as RAID. I have a Win 7 box that the drive detection is set to auto (Gigabyte G41 ICH7 HDMI), and system info (BIOS) is saying that the transfer mode is SATA 300, so (.) or (?) or (!) as the case may warrant. I thought that this was the big deal with Vista also, that it would run ACHI and XP wouldn't. At least that's what the BIOS in my G965 Intel board was telling me.
     
  6. mailpup

    mailpup TS Special Forces Posts: 8,452   +227

    I missed that part for some reason. So yes, you will have to do a Windows repair or if that doesn't work, as captaincranky said, a fresh install.
     
  7. captaincranky

    captaincranky TechSpot Addict Posts: 10,811   +921

    Even if you only changed the motherboard, the best you could hope for is a Windows message telling you that you have "3 days to reactivate Windows".

    No Windows operating system since XP will tolerate that dramatic a change in hardware without complaint.

    In fact, XP Home won't even read a HDD from Win XP Pro. Well, it'll read it, it just won't let you look at it.
     
  8. 4doormonster

    4doormonster TS Rookie Topic Starter

    there is no other os present ive reinstalled windows 7 a few times since the start of this thread trying the different options for the sata controller (ide and ACHI). windows would not format or install on the AHCI setting. the motherboard detects both drives fine and boots from the proper drive in the above configuration but i still cannot see the files (slave) drive in windows 7 under the computer tab like before

    edit: oh and if it helps i can hear the drive spinning up every once in a while in windows just like it used to
     
  9. captaincranky

    captaincranky TechSpot Addict Posts: 10,811   +921

    Is the SATA drive now the OS drive, and is it running as IDE?

    You could download a copy of "Ubuntu" Linux, Cold boot with that in the DVD drive, then do a live run to see if it can see your files on the drive in question. Whichever one that is, since you're not being specific as to which drive cannot be read now. The IDE or the SATA, talk to us.
     
  10. 4doormonster

    4doormonster TS Rookie Topic Starter

    both drives are sata (if im correct this means they use the nice flat thin cable with the small connectors...i know they are not the round ide cables) so yes the os drive is sata and they are running in ide mode but the "SATA Port 0-3 Native Mode" setting is disabled. Is there a chance i have these plugged into the wrong sata ports? i thought it did not matter where you plugged them with sata.

    ps: im sorry im being as informative as i can i jsut have trouble explaining problems like this in text, also my mobo only has 1 ide slot and it only supports 2 drives which are being occupied by cdrom drives if that info helps at all
     
  11. Kevork

    Kevork TS Rookie Posts: 92

    Are you basing youself ony on "My Computer" Did you verify the through the Disk Management utility?
     
     
  12. 4doormonster

    4doormonster TS Rookie Topic Starter

    im basing this on my computer. i dont know of a disk manager utility

    quick edit: both my drives ARE detected in device manager though

    here is what it lists them as:

    Master (OS): Maxtor 6Y080M0 ATA Device
    Slave (Files): ST31000340AS ATA Device

    (does not list as master or slave that is just there for info)
     
  13. Kevork

    Kevork TS Rookie Posts: 92

    Hi,

    Search for: diskmgmt.msc

    Open the utility and verify in the utility if the drive has been detected. Windows will not display a drive in the " Mycomputer" list by default if:

    1) No partitions are on the drive.
    2) The drive is not setup in the utlility.
     
  14. Kevork

    Kevork TS Rookie Posts: 92

    Sorry what I meant by search is:

    Click "Start" (or windows logo if you prefer)
    Under "Start Search" copy paste diskmgmt.msc
    Under teh programs list it should populate.
     
  15. 4doormonster

    4doormonster TS Rookie Topic Starter

    :D problem solved!!

    i just needed to add a drive letter in the disk manager and 30 seconds later its working thanks guys...ive been unplugging and plugging these things in for hours already haha
     
  16. Kevork

    Kevork TS Rookie Posts: 92

    Good news! Rule of thumb when isntalling SATA drives. Always check the disk management utility first!
     
  17. captaincranky

    captaincranky TechSpot Addict Posts: 10,811   +921

    It is true that a HDD will not display in "Computer", if it isn't formatted, but I transfer drives with data on them between machines all the time, and they're auto detected, and assigned drive letters without intervention on my part. I suppose I should consider myself "lucky" (!) or (?) As you know, you can also get to disk management via "Control Panel" > "Computer Management" > "Administrative Tools"> "Disk Management". Hey, you may not always the instruction set handy to copy and paste. I''m jus' sayin'.
     
  18. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,373   +167

    Another set of mouse clicks to do the job: rt click My Computer->Properties->Manage->Disk Management

    @captaincranky: Try these too. I think they're actually a bit quicker as you don't have to wait for Control Panel to load
     
  19. 4doormonster

    4doormonster TS Rookie Topic Starter

    i think i remember doing this once before and this was the way thanks again everyone!!
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.