Help installing my new ATI Radeon video card

By Baldrik
Jul 18, 2009
Topic Status:
Not open for further replies.
  1. I just bought an ATI Radeon 9550 109-A03500-10 256mb AGP video card on ebay, but the seller didn't include any software, so I went to amd support and downloaded the full Catalyst suite.

    I can't figure out how to get things working now, because Catalyst setup can't find the hardware, and "Update Driver" in Device Manager can't find Catalyst.

    Also, Windows doesn't know what to do with it when I boot up.

    I'm on Windows XP Home Edition, Service Pack 2.
  2. strategic

    strategic TechSpot Paladin Posts: 1,274

    Is your Windows up to date?
    Do you have the Microsoft .NET Framework installed?
  3. Baldrik

    Baldrik Newcomer, in training Topic Starter

    Control Panel shows Microsoft .NET 2.0 installed.

    What I might need is a link to install instructions. I'm not sure I'm doing things in the right order. When I run the ATI software setup, it says:

    "Setup was unable to find components that can be installed on your current hardware or software configuration. Please make sure you have the required hardware or software."

    When I look in Device manager, the Radeon card is not there. The only way I know of to get the card recognized by Device Manage is to reboot, but when it boots up, Microsoft can't find a driver for it, and when I try to point it to the Catalyst files it says it can't find the right ones. I don't know what I'm supposed to do to install this thing, so maybe I'm just performing the wrong actions or doing things in the wrong order.
  4. strategic

    strategic TechSpot Paladin Posts: 1,274

    Net 2.0 should be sufficient since the graphics cards isn't all too new. Did you follow through any of the steps on the AMD support page? Are you the Admin on the PC? Do you know for sure that the card even works?
  5. Baldrik

    Baldrik Newcomer, in training Topic Starter

    The install steps on the AMD support page are basically, "Click the exe." Yes, I followed them, but it didn't end the way it was supposed to (see the message in my original post).

    Yes, I am the admin.

    Does the card work? When you buy on ebay, you can only hope. I think it does because when I let Windows try to find the driver after a reboot, I pointed it to the temporary directory that I expanded the dowloaded exe in. It didn't work completely, but it did copy a bunch of files into the Systems32 folder before failing. After that I looked in Device Manager and the correct card was listed under Display Adapters. It is listed as disabled because the drivers can't be found.
  6. fimbles

    fimbles TechSpot Evangelist Posts: 1,241   +125

    Im pretty sure my old radeon 9600 required microsoft net framewok 3.0 to run catalyst control centre. The issues you are having sound more like a broken graphics card than a driver issue.

    Try this :

    Download driver sweeper here:

    http://www.guru3d.com/category/driversweeper/

    Use this program to search for and remove all traces of ati software, as an alternative you can use the ati software removal utility in add or remove programs.

    Ensure your windows is up to date and install net framework 3.0

    Remove and reseat your graphics card making sure all cables ect are connected (if present).

    Reinstall the correct graphics card drivers.

    If after doing these steps you are still having issues, i would suggest trying the card in a friends pc to be sure there are no problems with it.

    Hope this helps :)
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.