help installing new hard drive.

By RUDEBWOY
May 25, 2007
Topic Status:
Not open for further replies.
  1. i popped in my new maxtor 300 gig serial ata 300 now it had been found in the hardware panel but its not showing up in my computer any ideas?i try running the software cd wont go through im also on vista.
  2. Helgon

    Helgon Newcomer, in training

    I have the same problem

    I have the same problem. I just put in my new Samsung 250gb IDE into my computer. It wont show up under my computer, but it says it is detected in the bios, and in the system information.

    It's just something i've done wrong. But in bios my harddrives shows like this:

    IDE Primary Master: [NONE]
    IDE Primary Slave: Maxtor (this is the one with windows on)
    IDE Secondary Master: Samsung
    IDE Secondary Slave:[NONE]

    What is wrong? >_>
  3. RUDEBWOY

    RUDEBWOY Newcomer, in training Topic Starter Posts: 394

    well i fixed my problem i had to download the maxtory software from the site it seems that work with vista then run it and create the drive as a slave and it worked.
  4. Phantasm66

    Phantasm66 Newcomer, in training Posts: 6,504

    After fitting the drive, in order to get a drive letter, you need to partition the drive and format it.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.