TechSpot

Help: Very Unusual Drive Error ....

By sitk
Jan 28, 2005
  1. I have a HP OEM ASUS P4SD-LA and this was running fine, until, in my search for the perfect overlocking mobo, I flashed the BIOS with the retail version of this mobo, the P4G800-V. This went successfully, but there was a very unusual side effect. I currently have 1 USB External floppy drive, and for some reason everytime I restarted, a virutal (non-existent) floppy drive kept getting installed as Drive B: on my computer. Windows only saw this as " Floppy Drive" and my BIOS saw it as "1st Floppy Drive". The USB External drive was still working fine as drive A:\ . If I unistalled this floppy drive, it was reinstalled on the next restart. The only thing I could do was disable it, at which point it would stay disabled even on restart.

    But then it got worse....Since the new BIOS didn't control my fans properly, kept my CPU temp. high and had several other disadvantages, I decided to flash back to my original HP BIOS. This was also successful, but the floppy drive still kept being installed and it was still seen in the BIOS as "1st FLOPPY DRIVE". Plus there's 1 more problem. During my boot POST messages, AMI (my bios) gives me an error :
    A: Drive Error
    Press F1 for setup or Press F2 to continue
    If I press F1, it just goes into my BIOS(which I have tried everything in, with no success to remove this error)
    If I press F2, it continues successfully to Windows, but I would like to remove this message all together, because I do not want to press F2 to skip the message everytime.

    I have removed "1st Floppy Drive" from the Boot Device List all toghether but no luck. Plus this message is shown no matter what I boot off : HDD, Floppy, CD.

    Please help me remove this message all toghether. I believe the only way to achieve this is to somehow get rid of this peculiar non-existent floppy drive all toghether.

    Shane,
     
  2. Anarchi

    Anarchi TS Rookie

    There should be an "Enable onboard Floppy controller" option in the BIOS somewhere (its in the first page if you have an Award BIOS). so try disabling that since you dont have an internal FDD Drive.
     
  3. sitk

    sitk TS Rookie Topic Starter

    Sorry but no luck

    I'm sorry but I have a HP OEM Board (the p4sd-la) so it has very few options. It ahs options for onboard lan, firewire and audio but not floppy controller. And by the way, my BIOS is a AMI.

    Shane,
     
  4. NCSUFrenchie

    NCSUFrenchie TS Rookie

    HP desktop OEM motherboards have a setting in the BIOS that allows you to fix this feature. It seems that it may have been an erronious default setting because HP's desktop computers don't come with floppy drives in them anymore so they wouldn't need to have this option enabled. On the main screen of the BIOS (and this varies somewhat from machine to machine), there are the usual options: date, time, language, etc. But just below this is the option to disable the floppy disc. It has four choices: None, 720kb, 1.44Mb, and 2.88Mb.

    Hope this clears it up some :)

    Ian
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...