Help With Elder Scrolls:oblivion!

By computerkid
Jun 12, 2007
  1. ok so i just got a new dell and it deffinatly meets the system requirments but i still have some lag during game play. Does anyone know what this would be caused by?

    minimum sys. requirments for the game
    -windows XP
    -512 RAM
    -2GHz pentium 4 processor or equivilant
    -128MB video card w/ directX 9
    -dvd play and hard drive space

    "this is what i have"
    -windows vista
    -2GB RAM
    -intel duo core processor ( 2.8GHz)
    -256MB ati x1300 pro w/ direct X 9 (or 10 idk if it does or not)
    - and i have a dvd player and a 160GB hard drive

    ^^^ now you see why im confused on why i still have lag.?

    please help. e-mail= or AIM= jgroom3891
  2. beef_jerky4104

    beef_jerky4104 Banned Posts: 822

    The problem is your video card. The X1300 is the lower end version of the X1K Series. If you get a better video card that'll solve the problem.
  3. AtK SpAdE

    AtK SpAdE TechSpot Chancellor Posts: 1,495

    Is your game patched? Also you may want to investigate a mod called "oldblivion" which helps the game run better on lower end video cards.

  4. Lethogar

    Lethogar TS Rookie Posts: 36

    is there anything running in the background...I am not sure with vista it does take up some ram but what do you play that game on (i.e low med high).
    either way you should make sure that you are not running an anti viruses or spy-ware programs in the background.
  5. computerkid

    computerkid TS Rookie Topic Starter Posts: 51

    well lets see i think im running oblivion on the highest settings. and i dont have an anti virus thing or anything running. or well i do i have mc afee security thing on but its not running scans or anything. and what video card would you recomend that i get? since the ati x1300 pro is a little low end. something that i can run the game on high settings that isnt too expensive.
  6. mopar man

    mopar man TechSpot Ambassador Posts: 1,379

    Even if Mcafee isjust setting there, it is still hogging resources. Just close it.
  7. beef_jerky4104

    beef_jerky4104 Banned Posts: 822

  8. computerkid

    computerkid TS Rookie Topic Starter Posts: 51

    that card looks awsome but its says that these r the OS's that it works w/ "Windows 2000/XP/XPx64/MCE 2005" it doesnt say vista. will it still work on my comp if i have vista?
  9. MetalX

    MetalX TechSpot Chancellor Posts: 1,388

    Yes it will. Just beware that even with the most expensive (and powerful) videocard in the world, the GeForce 8800 Ultra, you still wouldn't get a perfect 60-70FPS constantly. Oblivion is extremely demanding, and even the most insane gaming rigs in the world can have problems with it.

    Also, Vista is worse for gaming than XP because it takes significantly more CPU power and RAM to run. I believe there is only one game that works better on Vista than XP (and only by a tiny bit) and that is Supreme Commander.

    And one more thing, is your CPU a Core 2 Duo or a Pentium D? It seems like it's probably a Pentium D because Core 2 Duos don't come in stock speeds of 2.8GHz, but Pentium Ds do. If it's a Pentium D... I feel sorry for you because frankly, they suck.
  10. beef_jerky4104

    beef_jerky4104 Banned Posts: 822

    MetalX are you saying that eVGA e-GeForce 8800 Ultra x2 SLi'ed would still lag?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...