Help with emachine w2260

By hnnshmom
Jan 13, 2006
  1. While reading the news the computer shut down. Then a burnt smell. Computer wouldn't turn back on after it happened last night.

    Today as soon as you plug in the power there is some noise (fan maybe) The power light doesn't illuminate, but the cd rom will open. There is no signal to the monitor.

    Does anyone know what could be the problem?
  2. monton

    monton TS Booster Posts: 110

    Dead eMachine

    It sounds like the power supply is bad. I've worked with 4 eMachines over the past few years and all had power supplies that died. 3 were dead dead, nothing happened when power button was pushed. 1 behaved as you described, a partial start. In this case everything turned on, fans, hard drives, etc. but then went dead. Having a spare PS lying around, I simply replaced the PS and everything was back to normal. Same with the other systems. 3 had the small proprietry PSs and the last had a standard sized PS.

    Anyway, I would check out the PS. I think other folks on this forum are better equiped to offer advise on testing a PS.

    Good luck
  3. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,377

    Ive worked on several eMachines where the PS has failed bucause of bad capacitors. Hopefully it didnt damage anything else but there is a good chance the motherboard was damaged. Any power supply can be swapped in there. Id get an Antec or Enermax. You can find them for under $45.
  4. kw5891

    kw5891 TS Rookie

    emachines w2260

    there a smell like tires in my tower before i notice my key board and mouse was odd. only could used in caps then the mouse when i click on item would pull up wrong window. before comp not rebooteding every thing was odd recycle bend was only icon that would pull up . so now my comp want power on help
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...