TechSpot

Help with parts

By mustangboy101
Jan 14, 2009
  1. Hey everyone. im fairly new to this site, an i;ve been reading other treads an it seemed like a very friendly forum.
    I just bought some parts off the internet. an i was wondering if those parts i bought were the right ones an would install perfect.
    My motherboard
    EVGA nForce 730a Motherboard - NVIDIA GeForce 8200, Socket AM2 / AM2+, ATX, Audio, Video, DVI, HDMI, PCI Express 2.0, Hyrbid SLI, USB 2.0, eSATA, RAID
    My CPU
    AMD Athlon 64 X2 5400+ Black Edition Processor ADO5400DSWOF - 2.80GHz, Socket AM2, 1MB Cache, 1000MHz (2000 MT/s) FSB, Dual Core, Brisbane, Processor, No fan
    Cooling Fan
    Ultra X-Wind Aluminum Socket K8/AM2 CPU Cooling Fan
    My videocard
    XFX GeForce 9600 GSO Video Card - 768MB DDR2, PCI Express 2.0, Dual Link DVI, SLI Ready
    I just want to know if im on the right track.
    i also bought this tower
    Ultra X-Blaster Black ATX Mid-Tower Case with Front USB, FireWire and Audio Ports

    I'd appreciate your feedback an opinions.
    thanks a whole lot
     
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    All this should go together fine. Good luck ;)
     
  3. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 5,431   +28

    Looks like a decent build, but I do not see a PSU. Do you already have one?
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...