Home Network Problems

By cslord15
Aug 16, 2003
  1. I have a cable hooked up to a Linksys Etherfast Firewall Router, with 3 computers on the network (all running Windows 98 SE.) Can someone tell me how I can configure the router and/or the computers in order to be able to access and transfer files between the computers?
  2. XtR-X

    XtR-X TS Rookie Posts: 863

    I was just about to post this same question. 'cept I have a D-Link firewall router thingamabob :D.
  3. Justin

    Justin TS Rookie Posts: 942

    If the router is acting as it should, and all your machines are sitting behind it (the router is acting as a firewall) then it is (relatively) safe to enable netBIOS / MS file sharing on all three.

    What you do, is under the properties of NETWORK NEIGHBORHOOD on each Win98SE PC, "ADD" the "Client for Microsoft Networks" service.

    Once each 98SE machine has that added, make each machine part of the same workgroup (found in the identification tab of network neighborhood properties)

    Once that is all finished, you can share directories you wish other PCs to access. One neat thing about netbios + tcp/ip under windows, is that you can use netbios computer names to initiate a tcp/ip connection in games. So rather then putting in, say, to connect to your other machine, you could put in "UGLYBOX" and it would resolve it properly.

    If you want to have blind full access on all machines, share the root of C: on each machine and all other partitions you want to share.

    Note: IF you do this, ensure that your router is filtering ports 135-139. Any machine that has netbios bound to tcp/ip in 9x, and any machine that has netbios bound to tcp/ip on an external adapter in an NT os, that has those ports visible to the internet, is extremely insecure and can potentially have its shares visible to the internet.

    If you have trouble with this let us know and I'll give you a detailed walkthrough.
  4. XtR-X

    XtR-X TS Rookie Posts: 863

    Okay, I'm running XP Pro. I need help on this. We're all on the domain HOME and we can't connect to the network.
  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Are you sure it is domain you have to belong to?
    A domain is a collection of machines on a network orchestrated by a Domain Controller and featuring central management.
    A workgroup is a rather loose collection of machines where all clients are equal.
  6. XtR-X

    XtR-X TS Rookie Posts: 863

    It's the workgroup home. My bad. I was explaining to my friend the whole concept of purchasing a domain yesterday and a little breifing on DNS.

    The workgroup, thanks for the correction.
  7. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Another point: a Windows Networking domain as a wholly different concept from an internet domain name. Thanks to the smart people in MS Silly Product Naming Department we have another pair cool confusing computer terms :p
  8. XtR-X

    XtR-X TS Rookie Posts: 863

    K how about the help now plz?

    But interesting... but not suprising.
  9. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Well, you need to have all the computers on the network set to the same workgroup, all must have Windows Networking and TCP/IP enabled and properly configured. Also, if any of them are running software firewalls, you may have to explicitly enable NetBIOS ports.
  10. Justin

    Justin TS Rookie Posts: 942

    As I mentioned above, NetBIOS will use ports 135 through 139. Also, in some cases you will have to manually enable netbios over tcp/ip for the adapter in question. See my above post for how to do this.
  11. XtR-X

    XtR-X TS Rookie Posts: 863

    So for my router config, I've got to add a rule that will allow all TCP and UDP connections thru ports 135 to 139 go through?
  12. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6


    Do not open those ports on the router. You will let the whole internet in your Microsoft network. (Blaster/Lovsan ring a bell? :p )

    You will need to enable those ports in your software firewall if you have any.
  13. XtR-X

    XtR-X TS Rookie Posts: 863

    Oh.... I will try that next week. Cuz no network here yet. I'll post feedback.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...