Home network stopped communicating

By sscohen0623
Apr 2, 2008
Topic Status:
Not open for further replies.
  1. Hi,
    I have 5 computers at home hooked up to a wired router (linksys befsr81). I have always been able to move files around between them. A couple of weeks ago another port on the router went out so I bought a new one and hooked it up last week. About the same time my network printer went out and I put a new one on through the router. I thought everything was fine, all computers were on line and printing fine. But when I went to move files around there were no other computers listed on any of the 5 computers. So I went Iand re-setup home networking on windows xp, made sure the drives were set for sharing but still nothing. I turned off Macfee & windows firewall, reebooting inbetween all these steps and still no communication between them.

    I talked with Linksys and they informed me there are no settings on the router to prevent communication between ports. I spoke with Canon (my new printer) and was informed that there was no way the printer did anything, especially since it could be used and seen by all computers.

    I put the old router back on and I get the same thing.

    So I'm pulling what's left of my hair out trying to figure this out. Any help would be gratefully appreciated.

    Thanks,
    Steve
  2. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,285   +155

    1. Are the computers all assigned to the same workgroup?
    2. Reset the router to factory defaults (there should be a reset button for this - often recessed and accessible by sticking in a paper clip). Check the user guide if you don't know how
    3. You mention file sharing so want to double check.. when you say the computers can't see each other, you are looking via My Network Places? None of the computers are listed?
    4. since you used the wizard should be ok. but may as well double check LAN properties for the Network Connection on the computer. You should see these included
    - Client for Microsoft Windows and
    - File and Printer Sharing for Microsoft Networks
    - Internet Protocol (TCP/IP)
  3. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,285   +155

    oh. And also try this tool Look@LAN. It identifies computers on the LAN at a lower layer then the applications. So even if the higher level application protocols are screwed up and don't show computers, check if you can see them with this tool
  4. sscohen0623

    sscohen0623 Newcomer, in training Topic Starter

    Thanks,
    The computers are all on the same workgroup.
    I will try the reset again. Did it once already and added firmware update.
    I'm looking ubder "My Network Places" and no other computers are listed there.
    I checke the LAN properties and all are there checked.
    I down loaded look@lan. Don't know how to use it or what I should look for but there are 2 other computers on right now and it shows 4 total. 2 of which look fine (1 is the printer and the other this computer) and the other 2 have no info and are in the red.

    Steve
  5. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,285   +155

    OK. will take a short while (am working on) instructions
  6. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,285   +155

    Ok. Starting from the beginning
    1. When you start LookLan click Create New Profile
      • Enter any text for Profile Name
      • Click on an IP address for interface. There is one IP address for each network connection on your computer. Best to select the IP of the LAN connection to your router (if you see more then one)
      • Do not change the default scan range yet
      • Click Next
    2. Wait till it finishes scanning your LAN
      • You can see the Network Discovery Scan bar advance till it reaches 100% when done
      • When done, the lower pane displays the list of IP addresses it found on your LAN that fall within the default scan range of IP addresses used. It used the default range 192.168.0.0 to 192.168.0.255.
      • If you know your LAN uses IP addresses outside of that range (e.g. some routers will use 192.168.1.xx) or you just want it to scan a wider range (but be patient while it takes longer) you can modify the scan range by clicking View->Scan Ranges and you can add additional ranges
    3. Click on Refresh button under Network Discovery Scan bar to do a new scan (with any new range of IPs)
    4. If you highlight an IP displayed in the lower pane, right click and select Do Proof Scan. It may take a bit to finish, but will provide you more detailed info on the IP it sees including the standard network services ports it sees open

    Note: If the IP is appearing that alone is proof that its packets (at least some other network packets) are passing through your router and arriving at the host computer you’re running on now.

    /***** Edit *****/
    Not bad for a freeware tool, i think.

    /**** Edit *****/
    And the purpose of this first step is proving if there really is network connectivity between devices and what the network monitor can see
  7. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,285   +155

    btw.. to be sure (or redo the test if a device still doesn't appear)

    for the purpose of this test. you should (in this order)
    1. Remove the WAN cable from your router to keep the outside world outside!!!
    2. Turn off all your firewalls on every computer
    3. Run Look Lan
  8. sscohen0623

    sscohen0623 Newcomer, in training Topic Starter

    It sees four IP's I know there are 3 other things on right now besides my main computer and one is the printer. The other 2 show "not Windows" but they are all winxp. I will do the reset on the router now to see it that helps.
    Thanks,
    Steve
  9. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,285   +155

    ok...

    and be sure to unplug your WAN /turn off firewalls (see my post above)

    and try installing LookLan on the computers not showing up.. What does it see from their point of view? and check their setup/connectivity/etc just with IE if they can get a web page and connect anywhere
  10. sscohen0623

    sscohen0623 Newcomer, in training Topic Starter

    Reset router. Turned off firewalls. When I ran look@lan it was down to 3 IPs. One is this computer. I think 1 is the printer and the other the router. not seeing anything else. I've checked all the settings on the other computers. I'm trying to get it communicating with just one right now but nothing seems to be working. It seems strange that the other computers can print and access the internet through the same router but not see each other. There has to be something that is common to all and the only thing is the router or the printer. But the printer just plugs into the router. I unplugged the printer and I still have the problem.

    So I don't see how each computer could have changed it's settings. But I'm no expert.
    What do you think?
    Steve
  11. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,285   +155

    agreed.. is very strange.

    1. what;s the version number of your linksys befsr81 router? What firmware version are you running?
    2. Have you modified the scan range on LookLan? I see your router defaults to IP 192.168.1.1. So LookLAN will never see that IP if you're still using the default scan range. Add the range 192.168.1.0 to 192.168.1.255. You also probably noticed you can save and then open a LookLAN profile so you need not reenter everything each time you start LookLAN. Just open the same profile each time.
    3. Have you power cycled everything? (turn everything off then bring 'em up one at a time.
    4. Log into the router and look at Local Network Screen and DHCP Client Table to see the list of IPs the router assigned computer connections on your LAN.
    5. Look at the router NAT table. The factory reset should have cleared all entries. But if entries are in there, they can control the routing.
    6. Borrow a friend;s router and try using it instead to see if it makes a difference
    7. After power cycling everything, identify the IPs and the computer they belong to. You can see all the IP info on each computer (and the assigned IP address) by clicking Start -> Run the enter cmd. Enter ipconfig /all. You can also copy/paste its output into a text file if you want to post it back here. Note that the computer's IP address can changed from time to time by your router (probably when the computer boots so check while they're all up and running)
    8. You can also have LookLan export the IP data into a text file so you can post that data here as well. File -> Export as -> ANSI Text
  12. tipstir

    tipstir TS Ambassador Posts: 4,492   +73

    Sounds like the same problem I was having with my network here. But the problem is gone after I turned off Master Browser

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters]
    "IsDomainMaster"="FALSE"
    "MaintainServerList"="No"

    click on start
    click on run
    type: services.msc

    Computer Browser: Not Started / Automatic
    Network Connections: Started / Automatic


    Do this on all PCs in your network..
    Also do not use simple file sharing method make sure that box is uncheck on all PCs on your network. In my case 8 had to be re-done. It's not the router or switches it is one or two PCs are the network acting up..

    There is a free tool from Microsoft called Browstat.exe:
    Browstat status would tell you the condition of your workgroup or Browstat sta
    When I first ran this program without using the script above I got errors so some PCs on the network were acting like the Master Browser.

    To make one PC on your network to act as the Master Browser (or server)

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters]
    "IsDomainMaster"="TRUE"
    "MaintainServerList"="Yes"

    click on start
    click on run
    type: services.msc

    Computer Browser: Started Automatic
    Network Connections: Started / Automatic


    This LookLan program I didn't know you can use it to discover like this Steve good job..
  13. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,285   +155

    haven't heard of browstat tool before. thanks for that tip

    i could see how computer browser service could cause the problem reported as well as interfere with seeing other computers via My Network Places though i wouldn't have guessed it would affect LookLAN's network monitor function

    In any case, sounds like browstat and looking at the Computer Browser service is the best bet and way-to-go at fixing the problem.

    Though, sscohen0623, if you have the chance, if you could add that second port scan range in LookLan to include 192.168.1.0 to 192.168.1.255 in addition to the default range would be helpful (for just for my own knowledge) to know if the other IPs will appear or if the computer browser problem can interfere at the network monitor level as well.
     
  14. tipstir

    tipstir TS Ambassador Posts: 4,492   +73

    Try it does work, and these services to stopped sometimes caused by other programs you install. Hope it helps...
  15. sscohen0623

    sscohen0623 Newcomer, in training Topic Starter

    Ok, I changed the registry and turned off simple file sharing. rebooted multiple computers and still nothing. Checked Router and NAT is set to enable but I don't see a table. Router version is 3.1 and the firmware is 2.51.3 from 3-2-07.
    Did I miss anything?
    thank you both for your help.
    Steve
  16. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,285   +155

    One last shot before i'm done for the night.

    To simplify things I’d turn off all your LAN equipment except for two (or whatever the magic number of) computers that are having the communication problem. Then we’re going to double check firewall, netbios, computer browser service, and your LAN connectivity.

    Make sure Windows Firewall is still off.
    (I’ve seen it sometimes / somehow get turned back on) In Control Panel select Security Center. Scroll to the bottom of Security Center window. Click Windows Firewall under Manage Security Settings. Make sure Windows Firewall is set to OFF.

    Enable Netbios and make sure Computer Browser is started
    Make sure that NetBIOS over TCP/IP is turned on and that the Computer Browser service is running on each computer in the workgroup.
    Enable NetBIOS over TCP/IP
    1. Click Start, click Control Panel, and then click Network and Internet Connections.
    2. Click Network Connections.
    3. Right-click Local Area Connection, and then click Properties.
    4. Click Internet Protocol (TCP/IP), and then click Properties.
    5. Click the General tab, and then click Advanced.
    6. Click the WINS tab.
    7. Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.
    8. Click Close to close the Local Area Connection Properties dialog box.
    9. Close the Network Connections window.

    Verify the Computer Browser service
    1. Click Start, right-click My Computer, and then click Manage.
    2. Double-click Services and Applications.
    3. Double-click Services.
    4. Scroll to the entry for Computer Browser. Verify the Startup Type is set to Automatic.
    5. Verify Computer Browser Status = Started. If not Started let me know and to select Start
    6. Also see that one computer is set as the master per tipster’s post

    I’d like to see the LookLAN results
    When you start LookLAN create a new profile.
    · Pick the IP address for the network interface
    · This time, click Manually Specify Scan Range
    · Set the scan range to be 192.168.0.0 to 192.168.1.255. (Note it’s now the last 2 digits of the range that should be different). Click Next and wait for scan to complete
    · Click File -> Export As -> ANSI Text to write the IP info to a text file
    Copy / Paste the content of that text file into your next post

    --------
    You can also go look into the Windows Error Log and set the filters to not display Information messages. if u don't how, tell u tomorrow. Or just google for Event Log Explorer is a tool that makes it easier to see. Look for errors. Especiall any errors from Computer Browser
  17. sscohen0623

    sscohen0623 Newcomer, in training Topic Starter

    I will try this out tomorrow.
    Thanks,
  18. jobeard

    jobeard TS Ambassador Posts: 13,037   +222

    this picture will help

    Notice Active Services show ports 139,445 as having processes attached.
    Port 135 is the naming service.

    Working thru Microsoft Windows Network->Entire Network->Workgroup (or MSHOME.. whatever)
    you will get a list of systems that 'can be seen'. If one or more are missing, then
    the firewall on the missing system needs attention.

    At least one system on the LAN must be a Master Browser
  19. tipstir

    tipstir TS Ambassador Posts: 4,492   +73

    Yes one system on the workgroup has to be the master browser
  20. tipstir

    tipstir TS Ambassador Posts: 4,492   +73


    Steve,

    1. turn off all PCs on your network
    2. turn off the router
    3. turn on the router
    4. connect only one PC to the router
    5. wait until you get a connection from the router to the PC
    6. make sure that PC you've connect will be the Master Browser
    7. under the DCHP Client Table make sure you can see this PC
    8. check to see if you can access the internet

    If everything works then move on to another PC..
    Do steps 4 thru 8

    Do this for each PC but one at a time...

    Step 9 check to see if the second, can see the first and also be able to access shared files. Do not go over board just take your time and make sure you catch everything. You have a lot of good advise here just use it to fix your problem. Otherwise you'll be at your climbing the ladder as they say and get not good results.
  21. sscohen0623

    sscohen0623 Newcomer, in training Topic Starter

    Sorry I haven't been back yet. I've seem to have screwed up my connection. It went offline and then asked to dial a bluetooth dun? I dont't have a phone line plugged in. And when I went to check the configuration it kept shutting me out. So after a while on the phone with charter I'm back. Needed to reset my modem & router.

    SO back to the problem.
    I only have one other computer on besides the printer plugged into the router.
    I set the master browser on this one and turned it off on the other.
    Firewalls off.
    look@lan is:

    192.168.1.1 ONLINE Same LAN NOT WIN - - - - -
    192.168.1.100 ONLINE Same LAN WINDOWS HP0015604736B4 000000CFA24A (n/a) - -
    192.168.1.114 ONLINE Same LAN WINDOWS Office9100.nv.charter.com OFFICE9100 (n/a) - -

    Checked NETbios it is set correctly as well as computer browser.

    Still same.
    Thanks again for helping me with this.
    Steve
  22. sscohen0623

    sscohen0623 Newcomer, in training Topic Starter

    Ok something new. When I checked DHCP active IP Table it showed the other computer. So I quickly went to explorer and checked my network. Under Microsoft Windows Network it showed my workgroup. When I clicked on it it showed the other computer. But when I clicked on that computer I get an error message saying the computer is not accessible, I might not have permission to use the network resource and the network path was not found.

    On the other computer I can't get past the workgroup before I get the same message.

    Steve
  23. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,285   +155

    That's making progress.

    Getting things to the point where, from each computer's point of view, you can see every other computer in the workgroup is a good first goal (in my own approach to this problem). Getting each computer beyond the "No permission to use the network resource" just means there's a little more bookwork to be done in the resource sharing settings for each computer.

    So...
    192.168.1.1 Is your router. It will always have that IP address (unless you decide to change the settings in the router)

    I think it'll help to start referring to each of your computers by its unique name from this point on so its clear which one we're talking about. If you look at My Computer -> Properties and click the Computer Name tab, verify each computer name is unique within the workgroup. Then list for us:
    Computer Name, Operating System, Computer Make/Model
    when you list Operating System be sure to include Service Pack level and distinguish XP Pro vs XP Home

    Looking at the other entries in LookLAN, first note the IP address your router assigns each device may change but each computer will always be uniquely identified by its computer name listed under Netbios Name. So we see:

    192.168.1.100 is your printer
    192.168.1.114 is your computer named OFFICE9100

    For followup,
    1. List the info for each computer by Computer Name
    2, After you've attempted the startup process outlined by tipster for each computer (and wait a few minutes after you've completed the last computer) post the LookLAN output to show what IPs are or are not showing up
    3. Indicate (by computer name) any computer you're unable to see viewing Microsoft Windows Network from a different computer
    4. For each problem computers identified in 3) click to highlight the computer in LookLAN, then right click and select Do Proof Scan. Look at Active Services and as joebeard mentioned would expect ports 135, 139, 445 to all be assigned.

    You can report back and, fyi, here's some handy info about File Sharing tho specific to XP Pro others OS are similar and can work out the specifics once you post back.
  24. sscohen0623

    sscohen0623 Newcomer, in training Topic Starter

    Thanks, I will work on it this afternoon and post back.
    Steve
  25. sscohen0623

    sscohen0623 Newcomer, in training Topic Starter

    Workgroup OFFICEMAIN
    192.168.1.114 Office9100 (My main computer) Win XP media center sp2
    192.168.1.102 TV Win XP media center sp2
    192.168.1.104 Laura Win XP Home
    192.168.1.101 Jamie Win Vista Home Basic
    192.168.1.103 Laptop Win Vista Home Premium

    192.168.1.1 Router
    192.168.1.105 ? Listed on Mcafee network manager
    192.168.1.100 ? Listed on Mcafee network manager

    For each computer using - My network places \ entire network \ Microsoft windows network \ officemain

    From OFFICEMAIN I can see the 5 computers but no access.
    Look @ LAN
    192.168.1.1 ONLINE Same LAN NOT WIN - - - - -
    192.168.1.100 ONLINE Same LAN WINDOWS HP0015604736B4 000000CFA24A (n/a) - -
    192.168.1.114 ONLINE Same LAN WINDOWS Office9100.nv.charter.com OFFICE9100 (n/a) - -
    Proof scan 135 green check, 139 blue check, 445 blue check & 1025 blue check

    From TV I can see workgroup but not beyond that

    From Laptop I can see Jamie & Printer but no access to Jamie

    From Laura I can see workgroup but not beyond that

    From Jamie I can see Laptop & Printer but no access to Laptop

    From router DHCP Client table
    DHCP Server IP Address:
    192.168.1.1
    Client Hostname IP Address
    192.168.1.100
    Jamies 192.168.1.101
    192.168.1.102
    Laptop-PC 192.168.1.103
    Laura 192.168.1.104
    Office9100 192.168.1.114

    I have not istalled look@LAN on any other computer. Should I?
    Thanks,
    Steve
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.