TechSpot

How can I stop my lappy from going to sleep all the time?

By Envergure
Aug 26, 2008
  1. :mad: My Acer Aspire 5920 puts itself to sleep - whether plugged in or not - after it's had no input for long enough (i've never been there when it went so i don't know exactly how long). This sucks royally because i leave it on overnight sometimes to run downloads and they always fail.

    I already have everything set to "never" in Power Settings.

    Is there a way to stop it doing that?



    Vista Home Premium 64b
     
  2. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Seems to be on some Vista computers, that you cannot turn it off !!
    Therefore, you could set it to not turn off for 15Hrs (ie overnight and more)

    You could use this batch file (ie save to Notepad, the save as, all files, PConfig1.bat, then run it with Administrator rights (just right click on it)
    Anyway, here it is, I found the batch file here: http://www.howtogeek.com/howto/windows-vista/disable-power-management-on-windows-vista/
    Let me know if it works
     
  3. mscrx

    mscrx TS Rookie Posts: 829

    did you check the settings in the bios as well? donno about acer laptops but I can do this settings in my dell laptops bios...
     
  4. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    The "workaround" I provided above was because many users are reporting this issue, even if Sleep (or anything to do with Power Management (proprietory or windows) is turned off, in Vista (on some laptops)

    Therefore actually turning it on (rather) and setting it for a long delay (many hours) seems to be the best answer
     
  5. Envergure

    Envergure TS Enthusiast Topic Starter Posts: 154

    Setting a long delay worked. I set it to 100 hours and so far so good.
     
  6. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Thanks for the update :grinthumb
     
  7. mscrx

    mscrx TS Rookie Posts: 829

    I didn't say I doubt that but I have 3 laptops (dell, lenovo, hp) running Vista without this kind of problem. so, nice workaround but this to me seems not be a common problem in vista.
    I do alot of workarounds every day but I rather find a solution than working everything around. no offense but thats lazy :) or maybe I am too german at this point...
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.