TechSpot

How do I update my video driver?

By puertoricanchic
Sep 25, 2005
Topic Status:
Not open for further replies.
  1. hey guys umm i installed world of warcraft and everything and i clicked on the icon to actually play the game and it sed ''world of warcraft was unable to start up 3d acceleration. please make sure directx 9.0c is installed and your video drivers are up to date.'' i installed the full package of directx 9.0 and it still wont let me play. i kno absolutley nothing about my video drivers. please help? thanks.
  2. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,763

    Right click on the Desktop and select Properties and then Settings. That will tell you what video you have.
  3. DonNagual

    DonNagual TechSpot Ambassador Posts: 3,566

    If your video card is not integrated into your motherboard, then you want to find out if your card is nvidia or ATI (those are the two most common types).

    If it is nvidia, you go to www.nvidia.com and follow the links to download the drivers appropriate to your system. If your video card is ATI then you go to www.ati.com

    But your card may be integrated into your motherboard (if your computer was a budget computer this is probably the case). We would need to know the make and model of your motherboard to help you find the correct driver.

    Try running this program on your computer, and tell us the info (or give us screenshots) of what it says. http://www.techspot.com/downloads/27-cpu-z.html

    By the way, if your computer is a little on the old side, there is also the chance that your computer simply can not handle the game.
  4. Otmakus

    Otmakus Newcomer, in training Posts: 85

    Easier yet, u can run directx diagnostic tool (start-> run -> type "dxdiag" -> ok). U can find ur directx version in "System" tab, and ur video card in "Display" tab. If u still don't know what to do, post the info and we'll try to help u.

    World of Warcraft is a bit "heavy" game, so DonNagual is right, if ur comp is a budget comp or a little old, i'm afraid u just can't play it. Read the manual book for the game, it will tell u the minimum requirement to play it.
  5. wickedlady

    wickedlady Newcomer, in training

    I have a Nvidia Geforce fx 5200.. just bought it today.. i installed the drivers from the nvidia site and i have directx 9.0c
    but when i start world of warcraft it says "world of warcraft was unable to start up 3d acceleration. please make sure directx 9.0c is installed and your video drivers are up-to-date."

    so i started dxdiag and this is what it says:

    The file nv4_disp.dll is not digitally signed, which means that it has not been tested by Microsoft's Windows Hardware Quality Labs (WHQL). You may be able to get a WHQL logo'd driver from the hardware manufacturer.

    DirectDraw test results: All tests were successful.

    Direct3D functionality not available. You should verify that the driver is a final version from the hardware manufacturer.


    can anybody help me?? i dont know what is really wrong :S
  6. zsystempr

    zsystempr Newcomer, in training

    de q parte de puerto rico eres?
  7. johnnyg993

    johnnyg993 Newcomer, in training

    I have the same problem, except I was able to run WoW for 2 months before this happened to me. I don't know what to do.
  8. nightfox

    nightfox Newcomer, in training

    i had same problem

    i have the same problem but CPU-Z said i had no graphic interface HELP! me please
  9. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    Download an older driver and try to isntall that instead?

    Dxdiag just told you that DirectX acceleration is not available. Windows isn't giving it to you because you are having a problem with your driver(s) most likely.

    You mentioned you installed the latest driver, but the latest driver from nVidia will always be WHQL certified (aside from beta). Try downloading the nVidia Forceware drivers again. Uninstall your current video drivers through control panel (Start/Control Panel/Add/remove Programs/nVidia) and reinstall the new drivers.

    You may also need to install your chipset/board drivers. I have no idea what kind of motherboard you have, but nForce (nvidia nforce), VIA (Hyperion), ALi and SiS are pretty popular.
  10. nightfox

    nightfox Newcomer, in training

    fixed

    i fixed it by re-installing my graphicg drivers which were on a cd that came free with my dell
  11. WoWisntworking

    WoWisntworking Newcomer, in training

    WoW isn't working

    hey guys. Ive got the same problem with my world of warcraft. It says world of warcraft can not start up 3d acceleration pleas make sure direct x 9.0c is working and your video drivers are up to date.
    Some details:
    I have un-installed and re-installed WoW atleast 10 times
    I have installed direct x 9.0c more than twice
    My video card is a RADEON IGP 345M
    Please Help me for i havent been able to play for 2 months!

    Thanks Sam.
     
  12. nycrican

    nycrican Newcomer, in training

    HI Everyone:

    I had this same problem and I also have a Radeon card. This is how I solved my problem. For those of you who have cards from another company other then ATI, you may want to also try these steps:

    1. Use the add/ remove control panel to uninstall your Warcraft game and patches.

    2. Now reinstall Direct X over its previous install

    3. Use the add/ remove control panel to remove all your video drivers. You will now be

    using the default VGA driver provided with Windows. Stop the automatic found new

    hardware wizard from starting, everytime you reboot.

    4. Now for people with ATI cards go to:

    https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&folderID

    and download the correct Ati drivers for your card. Do not install yet.

    5. Now re-install the game and patch. After installing the game, try to start it, you will

    get the same error message.

    6. Now install your new video drivers and reboot.

    7. Now try starting your game, it should work. (At least it did for me, I spent 6 hours last

    Saturday figuring these steps out.

    Hope this solution helps. Nelly from the Block
  13. puertoricanchic

    puertoricanchic Newcomer, in training Topic Starter

    video driver.

    mmkay. thanks to all of the people who replied to my thread. i ran directx and this is what it said.

    Operating System: Microsoft Windows XP Professional (5.1, Build 2600)
    Language: English (Regional Setting: English)
    System Manufacturer: Sony Corporation
    System Model: VGC-RA825G(UC)
    BIOS: BIOS Date: 10/19/04 13:49:27 Ver: 08.00.10
    Processor: Intel(R) Pentium(R) 4 CPU 3.6GHz (2 CPUs)
    Memory: 1024MB RAM
    Page File: 523 MB used, 1937MB available
    DirectX Version: DirectX 9.0c (4.09.0000.0904)


    I've installed the latest version of DirectX more than 3 times.
    I went to my desktop, right clicked, and clicked properties. Then i clicked the settings tab and it said

    Display:
    (Default Monitor) on

    it didnt say anything about my video driver.
    im thinking it might be an ATI because i have a sticker on my computer that says ATI.
    But about 6 months ago this same computer let me play World of Warcraft and games such as that. But my stepdad came and deleted some of the things on the computer because it was going really slow. So i think he might've accidently deleted something that had to do with the video driver.

    please help!

    thanks.
  14. vnf4ultra

    vnf4ultra TechSpot Paladin Posts: 2,195

    I looked up your pc model, and found one pc like yours that has a ati x300le card. You can likely dl some ati drivers and install them, and resolve the problem. I guess you just would need the latest catalyst driver installed then, if you have an ati card.
    https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&folderID=27
    (if the link doesn't work, go to ati.com, go to drivers& software, go to win xp, radeon, catalyst, and dl the driver).
  15. nycrican

    nycrican Newcomer, in training

    HI Puertoricanchic:

    Did you follow all the instructions that I posted? My message is the one before yours. Try performing all the steps in the order that I wrote them, it should resolve your problem.

    Hope this helps. Nelly from the block
  16. nycrican

    nycrican Newcomer, in training

    Hi dmredman:

    Here are the steps. Follow them in the exact order as I wrote them and it should solve your problem:

    1. Use the add/ remove control panel to uninstall your Warcraft game and patches.

    2. Now reinstall Direct X over its previous install

    3. Use the add/ remove control panel to remove all your video drivers. You will now be

    using the default VGA driver provided with Windows. Stop the automatic found new

    hardware wizard from starting, everytime you reboot.

    4. Now for people with Via cards go to:

    http://www.viaarena.com/default.aspx?PageID=420&OSID=1&CatID=1070

    and download the second driver shown on this site. Do not install it yet.

    5. Now re-install the game and patch. After installing the game, try to start it, you will

    get the same error message.

    6. Now install your new video drivers and reboot.

    7. Now try starting your game, it should work. (At least it did for me, I spent 6 hours figuring these steps out.

    Hope this solution helps. Nelly from the Block




  17. Tedster

    Tedster Techspot old timer..... Posts: 10,074   +13

    most integrated graphics can't handle sophisticated games. It would be better to purchase a separate dedicated graphics cards for games. Then you will have to turn off and uninstall the graphics drivers for your integrated card and install the drivers for your video card.
  18. dmredman

    dmredman Newcomer, in training

    I need help

    Guys I am having the same trouble with World of warcraft as listed above. My computer has an intergrated video card..here are the specs u requested

    Motherboard

    Manufactuerer: ASUS Tech Computer Inc

    Model: Kelut 2.02

    Chipset: VIA KM400 Rev. 00

    SouthBridge: VIA VT8237

    Sencor: Winbond W83697HF


    BIOS

    Pheonix Technologies LTD

    Version: 3.10

    Date: 7/26/2004

    I need to know how to update this video driver
  19. nycrican

    nycrican Newcomer, in training

    Hi dmredman:

    The instructions I gave you earlier includes updating your video driver however if you only do that part, then your game is still not going to work because Active X will not let it.

    Trust me, it took me 6 hours to figure this out. So, if you follow my instructions, it will most likely solve your problem with Warcraft.

    Hope this helps.

    Nelly from the Block
  20. fishrailroad

    fishrailroad Newcomer, in training

    Temp Solution

    Hey guys, ive recently encountered the same problem with my ATI 9600, i found out though, that if you still have our disks (if you bought the card separate from your pc) you can go in and click install drivers, and when you get to the install option (automatic) or (custom) click custom, and proceed, you can select the ATI video driver near the top of the list, uncheck all others, INCLUDING direct x, i tried installing jus direct x and that didnt work (for me anyways), but install just the video driver and nothing else, then it will ask you to reboot, once youve rebooted, Wow should work, at least for a day or so, mine seems to get messed up around noonish every day, so meh, its a temporary solution, but ill post up again if i find a long term solution.
  21. Clarkee21

    Clarkee21 Newcomer, in training

    same problem

    I had the same problem and my video settings are set to allow all 3d acceleration
  22. bryank

    bryank Newcomer, in training

    Same problem

    I'm having the same problem.
    here is my.. info things.
    Operating system: Microsoft windows xp professional (5.1, build 2600)
    System Manufacturer: LENOVO
    System Model: 9636A44
    Processor: Intel(R) Pentium(R) Dual CPU e2180 @ 2.00GHz (2 CPUs
    DirectX Version: DirectX 9.0c (4.09.0000.0904)

    also. i have a 946GZ Express chipset family.
    and i when i try to update it. Mozzila freezes then it has (Not responding)



    o wait.. all fixed - all i did was google
    "946GZ Express chipset family"
    and followed a few links.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.