How to remove annoying xp setup option at bootup?

By bluelite
May 11, 2008
Topic Status:
Not open for further replies.
  1. I just recently upgraded my xp home to xp pro. Everytime I bootup the comp, it give me this option to boot with xphome edition or xp pro setup. Some how it did not give me the option for xp pro. However, when I choose the xp home edition it boot up to the xp pro. When I choose the xp pro setup, I get this error message " file missing or corrupt : <windows roots>\system32\hal.dll ". I just want to by pass this step to choose the boot up os and automatically load up xp pro. Any help will be appreciated.
  2. gbhall

    gbhall TechSpot Chancellor Posts: 2,327   +49

    You just need to edit boot.ini to remove one line and edit another. Google for 'boot.ini' there are plenty of instructions available. It might look confusing but it isn't.

    Mind you, I would want to know how your PC ended up with an apparently uncompleted XP-pro install first. But take a backup of boot.ini first so you cannot do any damage that cannot be repaired.

    After an upgrade you would have ended up with a dual-boot of home and pro anyway, and would still have to remove the option to dual boot if you didn't want it.
  3. bluelite

    bluelite Newcomer, in training Topic Starter

    Thank you for your advice. I really appreciated it.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.