TechSpot

HP Deskjet 6840 network problems

By bmyzer101
Feb 6, 2012
Post New Reply
  1. I have a client that I set up a wireless network for. We secured it using WPA2 and all computing devices work great using the WPA2 netkey. Now I am trying to set up the HP deskjet 6840. I plug it into the router and run set-up. When I tell it, it is going to be on a wireless network it goes into the security set up window it says that it detects that my wireless network is WEP and asks for the WEP netkey. Any ideas or experience with this problem and any idea how to fix it? It works great wired but the client insists that it has to be wireless. Added not: When I remove the security setting on the router I can set the printer up no problem. The printer is WPA capible.
     
  2. Buckshot420

    Buckshot420 TS Enthusiast Posts: 301

    What OS are you using? I'm using Windows 7 Professional 64-bit with a Lexmark X4850 wireless all-in-one so the exact process may differ.

    Try this first.
    Please verify that your router is not set for WPA2 Personal (aka WPA2-PSK). The Deskjet 6840 is a great printer (I had one for years) but it does not support WPA2.


    Next, let's try to manually configure the Deskjet 6840's network configuration via its internal web page.



    Connect the Deskjet to the router via an Ethernet cable, get the IP address from the router or by printing the Deskjet's network configuration page (press the button with the check mark) and browse the printer's web page at that IP address.



    On the printer's web page, select Network then Wireless. At this point you have two choices: use the Wireless Setup Wizard or go to the Advanced page and enter the SSID and WPA-PSK encryption key manually (don't forget to enable the radio and to set the mode to Infrastructure).
    Now unplug the Ethernet cable from the printer and you should be on the network. You can check by printing the network configuration page and verify that it has a good IP address.


    If that doesn't work, you can try this.

    Step 1: Set the print processor

    open Devices and Printers --> right-click the icon for your printer (Lexmark 4800 Series in my case)

    click Printer Properties -- > Advanced tab --> Print Processor button

    The default print processor is winprint and default data type is RAW. This does NOT work via wireless with the Lexmark (not sure about yours).

    Besides winprint, you should see another proprietary print processor on the list, e.g. Lexmark, HP, Dell. Select the print processor from your printer manufacturer. Set the data type to RAW, and hit OK.



    Step 2: Enable bidirectional support

    After setting the print processor, click the Ports tab. Highlight the port for your printer and check Enable Bidirectional Support.
     
  3. jobeard

    jobeard TS Ambassador Posts: 9,322   +622

    foolish, as under load it will impact other WiFi devices. IMO the sole advantage of WiFi printer is the freedom of location (ie no cables to run).
    Yea, I saw one even worse, the printer DEMANED WEP. Look for a firmware update for the printer.
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...