HP Pavilion ML350 won't boot

By mephisto_007
Feb 25, 2010
Topic Status:
Not open for further replies.
  1. Hi,

    When I turn it on the power supply fan will making a big noise as usual except it won't stop and the server won't boot either, i have not install any Hardware or Software that's would likely to conflict this machine and plus I have been using it as windows for a long time but I don't know what happen today it's just won't start/boot... can anyone help me out please, is it the power supply is dying? or something else... please
  2. mephisto_007

    mephisto_007 TechSpot Maniac Topic Starter Posts: 305

  3. mephisto_007

    mephisto_007 TechSpot Maniac Topic Starter Posts: 305

    anybody...........?
  4. dustin_ds3000

    dustin_ds3000 TechSpot Chancellor Posts: 1,128

    Sounds to me that your power supply died and you need a new one. What do you mean when you say "and the server won't boot either" you also have a Windows/Linux server that wont boot too.
  5. mephisto_007

    mephisto_007 TechSpot Maniac Topic Starter Posts: 305

    well normally when the start button turn on the power supply fan will spin vigorously and make a loud noise for a few seconds and back down normal following the start-up or POST sequence which implying the machine is OK, but in this case the power supply fan just spin and doesn't stop making that loud fan noise, and the screen is blank no POST no nothing...
  6. normanepps

    normanepps Newcomer, in training

    The best way is to start with what is needed to boot your computers. No extra cards or external devices. Then add until you find the problem.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.