TechSpot

HP tx1000z power cord problem

By daviddisasterga
Apr 9, 2008
  1. OKIE DOKIE tx1000z

    Ok so I bought a tx1000z the first week it was out which was like almost a year ago. I broke the power cord to it a few weeks ago and just got a new one today. However when I plugged it in the little blue light where u plug it in didn't turn on and it wont turn on either... When I first broke the cord I did attempt to fix it but stripping the wires and connecting them again that way which didn't work so IDK if that did something or what but I need help!!! And I did check the new power cord it is compatible with the laptop
     
  2. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Oh a HP Pavilion tx1000z laptop
    The exact last word of your post helped there.
    The problem with broken cords, is that you can basically short active to neutral (let alone the safety issue)
    This may have caused internal fault to the main board.

    Try removing the battery and power adaptor, holding in the ON button for 30secs (to disperse all internal voltage)
    Then plug the adaptor (the new one) in only
    Then turn it on

    If it doesn't turn on
    Confirm that you do have the correct power adaptor rating
    And then check your hardware warranty on the laptop !
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.