TechSpot

I can't play unreal engine games with my PC

By nemuro87
Mar 7, 2008
Topic Status:
Not open for further replies.
  1. I recently bought me a new PC and I experience problems I never had with the old one. I tried 2 of my favourite games, Deus Ex and Advent Rising and I couldn't play any of them.

    The problem is a bit hard to describe, the game seems to run faster than normal, and has some intervals in wich the game freezes for a few moments. And it makes it impossible for me to play.

    My pc has the following:

    Processor: AMD Athlon 64 x2 Dual Core 5200+
    Mainboard: ASRock ALIVE-ESATA2
    RAM: Dual Channel 2 x 1GB DDRAM2 667 MHZ PC 5300 Elixir
    Graphics Card: Galaxy GeForce 7200 GS 128MB PCI-Express
    HDD: 250 gb Samsung Spinpoint p120 on Sata (2 ? )

    Edit: I have Forceware Version 94.24 Installed for my Graphics Card.
    Edit/Delete Message
  2. Didou

    Didou Bowtie extraordinair! Posts: 5,899

    Old games sometimes have problems running on multi-core CPUs. Install the AMD Dual Core Optimizer & if that still doesn't work, launch the game, ALT-TAB back to the desktop, launch the task manager, set the affinity for the game's process to a single CPU core & then ALT-TAB back in the game.
  3. nemuro87

    nemuro87 Newcomer, in training Topic Starter

    Thank you so much, that really solved my problem. But now I have another one, the crosshair moves awfully fast inside of the game, tried minimizing the sensitivity, both ingame and in windows, but with no luck. The mouse seems to accelerate at a great rate, making it impossible to play.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.