TechSpot

ICS Help needed.

By Afforess
Jul 13, 2007
Topic Status:
Not open for further replies.
  1. Hi,

    I have 3 computers, 1 laptop running XP, 1 desktop runnign XP and 1 laptop running vista. I have been trying to share my internet (which is verizon wireless pc card 5750. It is faster than dialup, more like dsl speeds, but acts
    like dialup because it dials to connects.) I have a wired network with a netgear 104 ethernet hub. the laptop with vista has the internet connection. All of the computers have static ip's. The laptop with vista has ip 192.168.0.1 and a subnet mask of 255.255.255.0. The laptop running XP has ip of 192.168.0.2 with the same subnet mask and the defealt gateway is 192.168.0.1. The desktop running XP has ip of 192.168.0.4 and same subnet mask and defealt gateway. The computers all see each other, all pings are successful and I can share files. However on the laptop running xp I can see the internet gateway and it is connected but I can't access the internet on the computer. The desktop doesn't even show the internet gateway and also won't access the internet. The IE settings are on "automatically detect
    settings."

    What am I missing?
     
  2. herr5407

    herr5407 TS Rookie Posts: 118

    Have the ICS Server use the address of 192.168.0.1 and have the hosts use DHCP to grab addresses.

    Here is an excellent website that I thought would also give you some pointers if required. ICS
     
  3. jobeard

    jobeard TS Ambassador Posts: 13,426   +317

    ICS will demain the address 192.168.1.1 ...
     
  4. Afforess

    Afforess TS Rookie Topic Starter

    When I changed the Ip address from static to DHCP it gave it a new ip address and did everything. I can stil transfer files and see the internet gateway. However, the internet is still not working.
     
  5. herr5407

    herr5407 TS Rookie Posts: 118

    Hmm. The clients default gateway should be set to that of the ICS server.

    If your ICS servers IP is still 192.168.0.0, then set the default gateway of the clients there. If not, set the clients default gateway to the new IP of your laptop hosting the ICS
     
  6. jobeard

    jobeard TS Ambassador Posts: 13,426   +317

    well 192.168.0.0 is invalid and the addresses for the device connected via ICS
    should not be set manually.

    Make sure you have the ROUTING & REMOTE ACCESS SERVICE auto-started and
    enabled in the NIC used for the ICS connection.
     
  7. herr5407

    herr5407 TS Rookie Posts: 118

    yeah sorry. 192.168.0.0 is a network address and can't be used. duh.
     
  8. Afforess

    Afforess TS Rookie Topic Starter

    How do I check that?

    And why can I see the internet gateway and it is connected, yet cannot access the internet?
     
  9. herr5407

    herr5407 TS Rookie Posts: 118

    Control panel >> Admin tools >> Services.
    Scroll down to routing and remote access. Double click and change startup type to automatic. Click start. Close the window.
     
  10. Afforess

    Afforess TS Rookie Topic Starter

    Thanks! It was disabled! My internet works!
     
  11. herr5407

    herr5407 TS Rookie Posts: 118

    Don't thank me. Thank jobeard!
     
     
  12. Afforess

    Afforess TS Rookie Topic Starter

    Ok, I lied, I tried fixing the routing and remote access on my desktop. It worked, which is the reason for the above post. Now I tried the same fix on my laptop with XP and after I enabled routing and remote access i still cannot access the internet. So my desktop can and my laptop can't. My laptop's (XP laptop) ip is assigned by the DHCP and it shows the internet gateway and incoming connections.

    Why didn't the fix for one computer fix the other?
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.