TechSpot

IE7: "Your security settings to not allow websites to use ActiveX controls instal..."

By HaLo2FrEeEk
Jul 4, 2009
  1. I'm getting this error:

    "You security settings don't allow websites to use ActiveX controls installed on your computer. This page may not display correctly. Click here for options..."

    The only option there is More Information, which has nothing related whatsoever. I just reinstalled Vista, and I'm trying to install Flash. I've been able to fix this before by changing the security settings in Tools > Internet Options > Security > Custom Level. Here are my settings for ActiveX controls:

    Allow previously unused ActiveX controls to run without permission: Disable
    Allow Scriptlets: Disable
    Automatic Prompting for ActiveX controls: Enable
    Binary and script behaviors: Enable
    Display video and animation on a webpage that does not use external media player: Disable
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disable
    Initialize and script ActiveX controls not marked as safe for scripting: Disable
    Run ActiveX controls and plug-ins: Enable
    Script ActiveX controls marked as safe for scripting: Enable

    As you can see "Run ActiveX controls and plug-ins" is set to enable...so, why can't I run them? I've tried different ways of installing Flash, too. Usually, since I can't be bothered to go to adobe.com and find it, I go to youtube and click into a video, then follow the link. Usually that works, too, but not lately. And it's just been lately. It hasn't always done this, even installing from the same exact Vista disk...I don't know what the problem is!

    Can someone PLEASE help me out, and the quicker the better! Thank you in advance.
     
  2. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    Try these changes:
    Allow previously unused ActiveX controls to run without permission: Disable> Prompt
    Allow Scriptlets: Disable> Prompt
    Display video and animation on a webpage that does not use external media player: Disable> Enable
    Download signed ActiveX controls: Prompt> Enable
    Download unsigned ActiveX controls: Disable> Prompt
    Initialize and script ActiveX controls not marked as safe for scripting: Disable> Prompt

    Make sure Manage add-ons is enabled through Tools> Manage add-ons.

    I think the entry in red is the main problem.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...