TechSpot

Im stumped. please help

By filipmike33
Apr 3, 2008
  1. Hey guys, ive built a couple of pcs but now im in need of help. Let me give you a background first.

    So I bought a new case and transfered it, no boot, no post nothing. So I automatically assumed its a mobo failure (might have accidentally grounded it. So I got a new mobo *same brand same everything* but yet still nothing. RIght now im going barebones, just cpu, mobo, fan and ram. The fan is new, I went from a regular fan to a zalman 9700. Could that be it? please help
     
  2. filipmike33

    filipmike33 TS Member Topic Starter Posts: 34

    Could it be my power supply? if i have a faulty psu would it give me a no post?
     
  3. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Well I know this is critical and all, but have you unplugged the fan (5 Secs) and turned on (no doubt it will beep like mad - actually you could just plug another standard CPU fan in, holding it, to test)
    Yes
    Even if you get power light, the power supply may still be faulty
    Ideally test with another

    Actually the only ones you didn't mention, were Ram and CPU
    Both of these can cause the issue too.
     
  4. filipmike33

    filipmike33 TS Member Topic Starter Posts: 34

    Well I really dont think its my CPU or RAM, but i'll be picking up a new power supply tommorow since on my 24 pin, one of the square thing was empty??? is it suppose to be like that? never actually took the time to notice it. Im guessing its the psu.
     
  5. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    some mobos use a 20 pin, some 24. You need to consult the manual. The PSU should come with an adapter if necessary.

    Ensure your PSU is of adequate wattage. Use a calculator tool online and add 30% to the results.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...