TechSpot

In a dilemma

By omegafate
Feb 25, 2010
  1. ok i dunno if this is the right place to post it (cuz i havent been here in a long long while)

    well i acquired a ati radeon HD 4850 alightly used for a few months pretty much brand new. i poped it in and it came up a long beep then 3 short beeps, i checked the internet it a video card issue so i did the reseat,i did the driver install, i did the bios/cmos clear,i did the pci-e rail swap and reseat.

    ive been hammering the internet off and on cant find anything of help. as my specs read ive got a M2N SLI DELUXE mobo, 4 gb of quad channel ram (2 pairs paired up) amd x2 6000+, and win 7 ultimate 64 bit

    i canot try to put the vid card in another pc yet cuz the other pc im afraid of might be under powered and that pc isnt listed in the specs

    any info or ideas is welcome i thought id ask here since no one seems to be having this issue
     
  2. dustin_ds3000

    dustin_ds3000 TechSpot Chancellor Posts: 869   +8

    can you give us the specs on your PSU
     
  3. AtK SpAdE

    AtK SpAdE TechSpot Chancellor Posts: 1,495

    As mentioned the specs of the PSU of your system would help.

    Most video cards come with a decent warranty, in fact most brands have a lifetime waranty, so it may just be easier to RMA it.
     
  4. omegafate

    omegafate TS Rookie Topic Starter Posts: 104

    raidmax psu

    its the same one

    i meen it runs my 9800 gts pretty good
     
  5. dustin_ds3000

    dustin_ds3000 TechSpot Chancellor Posts: 869   +8

    well it looks like someone sold you a broke video card
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...