TechSpot

infostealer.Gampass and Hacktool.Rootkit

By bedroom
Mar 26, 2007
  1. Hi, can anyone help me wit this? Previously i've been notified that there is a hacktool.rootkit virus in my com. I updated my antivirus and it keeps popping out that my com is infected with infostealer.gampass. Any solutions?
     
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Very Important: Before deciding whether you should clean or reformat your system, go and read this thread HERE and decide what it is you want to do.

    If after reading the above, you wish to clean your system, do the following.

    Go and read the Viruses/Spyware/Malware, preliminary removal instructions. Follow all the instructions exactly.

    Post fresh HJT, AVG Antispyware and Combofix logs as attachments into this thread, only after doing the above.

    Also, let me know the results of the AVG Antirootkit scan.

    Regards Howard :wave: :wave:

    This thread is for the use of bedroom only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  3. bedroom

    bedroom TS Rookie Topic Starter

    hi, i've been stuck at the vundofix for almost 2 hours. Still scanning. Is it suppose to be this long?
     
  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    No, it shouldn`t take that long. It only takes a couple of minutes on my system.

    Stop it and try it again, if it still takes longer than around 15 to 20 minutes, stop it again and move on to the next tool.

    Regards Howard :)

    This thread is for the use of bedroom only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  5. bedroom

    bedroom TS Rookie Topic Starter

    the look2me-destroyer didn't re-open again. What could be the problem?
     
  6. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Don`t worry, just move on to the next tool/step. A rootkit infection can cause all kinds of weird stuff to happen.

    Regards Howard :)

    This thread is for the use of bedroom only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  7. bedroom

    bedroom TS Rookie Topic Starter

    hi, these are the files that you want. Sorry i took a long time.
     
  8. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    You might want to copy and paste these instructions into a notepad file. Then you can have the file open in safe mode, so you can follow the instructions easier.

    Boot into safe mode, under your normal user name(NOT THE ADMINISTRATOR ACCOUNT). See how HERE.

    In Windows Explorer, turn on "Show all files and folders, including hidden and system". See how HERE.

    Delete all files in AVG Antispyware quarantine.

    Open your task manager, by holding down the ctrl and alt keys and pressing the delete key.

    Click on the processes tab and end process for(if there).

    mpppds.exe
    wsvbs.exe
    upxdnd.exe
    msccrt.exe
    cmdbcs.exe
    c0nima.exe

    Close task manager.

    Run HJT with no other programmes open(except notepad). Click the scan button. Have HJT fix the following, by placing a tick in the little box next to(if there).

    O2 - BHO: (no name) - {7E853D72-626A-48EC-A868-BA8D5E23E045} - (no file)

    O4 - HKLM\..\Run: [mpppds] C:\WINDOWS\mpppds.exe

    O4 - HKLM\..\Run: [wsvbs] C:\WINDOWS\wsvbs.exe

    O4 - HKLM\..\Run: [upxdnd] C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\upxdnd.exe

    O4 - HKLM\..\Run: [msccrt] C:\WINDOWS\msccrt.exe

    O4 - HKLM\..\Run: [cmdbcs] C:\WINDOWS\cmdbcs.exe

    O4 - HKCU\..\Run: [rq] C:\WINDOWS\c0nima.exe

    Click on the fix checked button.

    Close HJT.

    Locate and delete the following bold files and/or directories(if there).

    C:\WINDOWS\c0nima.exe
    C:\WINDOWS\cmdbcs.exe
    C:\WINDOWS\msccrt.exe

    C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\upxdnd.exe
    C:\WINDOWS\wsvbs.exe
    C:\WINDOWS\mpppds.exe

    Reboot into normal mode and rehide your protected OS files.

    Post a fresh HJT log and let me know the results of the AVG Antirootkit scan.

    Regards Howard :)

    This thread is for the use of bedroom only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  9. bedroom

    bedroom TS Rookie Topic Starter

    Hi, my antirookit scan found no rootkit.
     
  10. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Your HJT log is now clean.

    Turn off system restore.(XP/ME only) See how HERE.

    Now, turn system restore back on. This will have deleted all your old restore points and any nasties that are in them. It will also have created a new, clean restore point.

    If you have any further virus/spyware problems, please post in this thread.

    Regards Howard :)

    This thread is for the use of bedroom only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  11. bedroom

    bedroom TS Rookie Topic Starter

    Hi, i'm back. ):
    after clearing the virus, everything is fine.
    But today when i switched on my laptop
    it came auto-shutting down for every 5 minutes.

    Is it because i didn't turned off the system restore?
    I once had a very bad experience doing that
    the moment i switched it off
    my whole laptop cannot be switched on.
     
  12. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Normally, any nasties in your system restore point are only dangerous, when you do a system restore. However, since you`re having problems, leave that for now.

    Can you post fresh HJT and Combofix logs?

    Also, let me know if you`re getting any error messages.

    Regards Howard :)

    This thread is for the use of bedroom only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  13. bedroom

    bedroom TS Rookie Topic Starter

    hi, i notice my com didn't auto shut down when i'm not charging.
    Could that be the problem?
    Because i charged my latop everyday. Without plucking out the charger.
     
  14. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Yes, I`d say that`s your problem right there. Your log files are clean BTW.

    Regards Howard :)

    This thread is for the use of bedroom only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  15. bedroom

    bedroom TS Rookie Topic Starter

    Hey thanks alot (;
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...