Installation Problems with the Sims2 Expansion packs (all)

By CountryBoy
Feb 22, 2007
  1. HELP
    Does anyone Know why all Sims2 expansion packs won't install . They get to 100% then when it comes to the making sure your game is up to date, it fails and " UPDATE PROCESS DID NOT COMPLETE SUCCESSFULLY. INSTALLATION WILL NOW TERMINATE " WTF I own all of the Sims2 packages including the Holiday edition core and nothing I do will work. If anyone can give me a solution please do. EA and MAXIS aren't helping with anything " Sorry, must Be YOUR computer" NOT....... Fresh install WinXP MEDIA 2005 Professional upgrade. Direct X 9.0 Upgraded, 300gig HDD with a 200GIG slave. HElp, lost..
  2. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    If you've applied any 3rd party cracks, nudity "patches", or no-cd cracks, the patcher/updater will fail. This is how they protect their games from piracy.

    If you own the original/core, I'd suggest:
    1) backup the entire My Documents/EA Games\The Sims 2 folder someplace safe. This has all your saved games and neighborhoods.
    2) Uninstall ALL Sims2 games in reversed order installed.. all the way back down to the original.
    3) Delete the entire game folder(s) after all Sims2 games are installed to ensure no remnants are left behind.
    4) Now, starting with the core Sims2 (whichever edition) install upwards from oldest -> newest that you may have. (Sims2, University, Nightlife, Open for Business, Pets then any Fun Packs).

    When all of the above are completed, launch Sims2 to verify it gets to the neighborhood selection properly. Exit Sims2, go to My Documents, EA Games, The Sims 2 and delete this folder (it's empty/freshly generated) and copy your backup from prior back into place.

    Good luck!
  3. CountryBoy

    CountryBoy TS Rookie Topic Starter

    Thanks, Sharkfood

    In answer to your instructions:
    I just installed a new 300gig HDD and everything was fresh install, I have been fighting with the Sims2 and expansion packs (all 7) to get them in a NEW HDD for over 26hrs now. There are no patches or cheats to apply since I can't get into the games yet.
    Problem #1... When it gets to the update check " UPDATE PROCESS DID NOT COMPLETE SUCCESSFULLY...INSTALLATION WILL NOW TERMINATE" then it removes that install of 100% automatically. #2....After the install of expansions *open for business, Family fun stuff and pets* the splash screen appears then dis appears, this is when it is suppose to give you launch screen, It doesn't, I have to re-boot to get rid of the PLEASE WAIT screen. End Program says it is the AutoRun7 prgm Not responding. And then every time I put the disk in to play, It intsalls again, it is a never ending loop.
    So if you have any other suggestions as to these, PLEASE tell me....Thank you anyway, I have printed and archived your instructions..
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...