TechSpot

Installed new graphics card (BFG 6800gs AGP) and all gfx are botched in all games!

By mattw
Feb 23, 2006
Topic Status:
Not open for further replies.
  1. [​IMG]

    all games look like that one^^

    i have tried updating the nvidia drivers, but it says its not compatible with my hardware config.

    i have updated the games with latest patches and they are still pants!

    this is not for my pc, but for my brothers.

    possible driver problem?

    anybody helps me please?

    thanks folks :)
  2. DonNagual

    DonNagual TechSpot Ambassador Posts: 3,566

    Looks like the card may be DOA (dead on arrival).

    But.... you can't update the drivers? That is strange. What are the system specs? Where are you trying to download the drivers from?
  3. mattw

    mattw TS Rookie Topic Starter Posts: 117

    oh crap...

    i downloaded the latest nvidia driver and it says it wont install because it isnt not required or something similar :s

    spec is:
    AMD Athlon 64 3400+
    Samsung PC3200 2 x 512 mb RAM
    200gb seagate baracuda hdd
    BFG 6800 gs
    360Watt Asus PSU
    ASUS K8-sla motherboard (i think)

    that computer was bought all together as a Hewlett Packard system, ive just changed the gfx card.

    and im downloading drivers directly from the Nvidia site.

    I will contact overclockers where i got the card from and see about getting a replacement card.
  4. DonNagual

    DonNagual TechSpot Ambassador Posts: 3,566

    Hmmm.... I have no experience with Asus PSUs. Take a look at the sticker on the PSU itself. How many amps does it put out on the 12v rail(s)?
  5. mattw

    mattw TS Rookie Topic Starter Posts: 117

    I will have to check tomorrow as it is in my brothers room and hes asleep.

    Could this problem be caused by lack of power through his PSU then?
  6. DonNagual

    DonNagual TechSpot Ambassador Posts: 3,566

    It is a possibility. Do you by chance have another machine you can test that video card in, or another PSU you can use to test in your machine?
  7. mattw

    mattw TS Rookie Topic Starter Posts: 117

    I can put my Antec 480W PSU in my bro's computer tomorrow.

    I will give that a go, and report back.
  8. DonNagual

    DonNagual TechSpot Ambassador Posts: 3,566

    It's certainly worth trying. My hunch is dead GPU, but before you go through the trouble of sending it back, might as well rule out the PSU.

    Good luck!
  9. DonNagual

    DonNagual TechSpot Ambassador Posts: 3,566

    Just did a bit more research on the ASUS psus... it looks like FSB (Fortron) has helped them develop their own line of PSUs. If that is the case, then ASUSs psus are probably very high quality and nothing to worry about...
  10. mattw

    mattw TS Rookie Topic Starter Posts: 117

    Quality, thanks for the help!
    I have contacted the BFG support team (getting responses very quickly which is awesome!) they said to try the card in another machine. I will bung the 6800 in my machine tomorrow as that currently has the Antec PSU in so it might be easier.
    I also sent them the image that i posted here. I will put it to them about the dead GPU maybe get a replacement sent out.

    I will get back to you as soon as i find out whether the card works in my machine or not.

    Thanks for the help.
  11. mattw

    mattw TS Rookie Topic Starter Posts: 117

    I put the graphics card in my machine and it worked perfectly!

    I have not got a clue what could be causing issues on my brothers pc!

    anyone have ideas? i have check the PSU and that is cooshdy with no problems.

    im still thinking its a driver issue, but the drivers on the disk with the GFX card are the latest ones out for the 6800GS.

    help is much much appreciated?
     
  12. DonNagual

    DonNagual TechSpot Ambassador Posts: 3,566

    The only thing I can think of next, is the motherboard's chipset drivers. If that doesn't clean you up, then try a bios update.

    How did you check the PSU?

    Also, how many other things do you have hooked up in there. Since it is only a 360w, it is possible that the power supply itself is fine, but 360w is simply not enough to power everything you have in that system.
  13. mattw

    mattw TS Rookie Topic Starter Posts: 117

    I have checked for latest BIOS updates etc, there arent any. same for chipset.

    The PSU is fine, BFG support said to download PCWizard and check something about the rails, and that appears to be okay.

    I havent added anything else to the system at all, i think 360W should be okay as i did temporarily add in my X850XTPE for a while, while i tried his card in my pc. and that ran perfectly coosh.

    I think i will try taking my PSU out and putting it in his PC and see how that goes.

    thanks for the help, much appreciated.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.