Intel HD 4000/NVIDIA GeForce GT 640M issue of games going to black screen

By Christopher71
Dec 23, 2015
Post New Reply
  1. Hello,

    I recently updated the family PC (Dell XPS all-in-one)to Windows 10. I have found issues with most games running in full screen mode. I get only black screen with sound as the game runs in the background. If I run it in window mode graphics work fine; Portal 2, Dungeon Defenders, StarWars Battlefront II... all old games so not stressing the machine. I have many more but I keep them aligned with what the machine can handle.

    I have the latest graphic's drivers (win10\64bit) and I have spent a lot of time trying to tweak the Geforce Control Panel to no avail. PC works fine until game is launched in full screen mode and then only audio. Lame... Not willing to lower my expectations or reinstall windows 10. I will fall back to Window 8.1 only as a last resort (suck). At my wits end on this issue as numerous Google searches have not helped. Any help would be much appreciated. (y)

    Basic Hardware information
    Motherboard: Dell XPS One 2710
    Central Processing Unit(CPU): Intel(R) Core(TM) i7-3770S CPU @ 3.10GHz
    Physical Memory: 8 GB
    Video Card X 2
    Intel(R) HD Graphics 4000 [v15.33.39.4276 (8/16/15)].
    NVIDIA GeForce GT 640M [v361.43 (12/21/15)].
    Audio Device X 4
    Realtek High Definition Audio
  2. Christopher71

    Christopher71 TS Member Topic Starter

    Sigh, I am a tard. Subject line says 650M but it is a NVIDIA GeForce GT 640M. If and Admin can update the subject it would be helpful. I cannot seem to edit the post on this forum.

    Moderator note: Updated. Let me know if that's not what you intended.
    Last edited by a moderator: Dec 23, 2015
  3. GeforcerFX

    GeforcerFX TS Evangelist Posts: 490   +123

    Have you removed all Nvidia and Intel Drivers graphics drivers and software and reinstalled there windows 10 version? If not that's Step 1
  4. Christopher71

    Christopher71 TS Member Topic Starter

    Thank you for your thoughts and yes I have completed clean installs of the drivers. Full removal and as noted by the driver versions the newest released windows 10 drivers.

    I have tried at least two versions of each of the Intel & Gforce win10 drivers. Was going to work backward to see if older versions worked an latest are not doing the trick.
  5. GeforcerFX

    GeforcerFX TS Evangelist Posts: 490   +123

    DO you have Optimus enabled?
  6. Christopher71

    Christopher71 TS Member Topic Starter

    Good question? How would I know.. Is it a service? I have done some review and am unsure how to manually change this setting. If it is in the Nvidia control panel I have certainly tried setting the game.exe to use the Nvidia.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...