TechSpot

Interresting issue. Address Bar (IE) not auto-adding 'http://' to addresses

By Vigilante
Apr 19, 2006
  1. So check it out, IE will not go to any page unless you manually type "http://" into the address bar. If you just type www.something.com, it won't even attempt to open, just sits there, but add http://www.something.com and it goes just fine. No 404 page or error page of anykind, it just sits there. If there is a page already open, it just stays on that page.

    The system suffered from some malware and a virus. But those are gone now. It's been scaned with a dozen tools, HJT is clean. I've reregistered a bunch of DLLs for fixing activex. I've reset the winsock, deleted hosts files, checked windows updates. And more.
    Firefox doesn't have the problem.

    I updated to IE 7 Beta 2 and it has the same issue! My googling isn't turning up much for this issue.

    I know the system is clean, but the malway it did have, probably muffed something in the registry or a file somewhere.

    So how can I get IE to automatically add http:// to URLs again? Anybody seen this nonesense before?
    thx
     
  2. SOcRatEs

    SOcRatEs TechSpot Paladin Posts: 966

  3. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

  4. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    Woops, you posted right when I did. Yes those must be the registry keys I needed to know. Definitely adding that to my favs. I guess the search settings reset those.

    thx
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...