TechSpot

IOMEGA HDD storage device 500GB problems

By wingy999
Sep 7, 2007
Topic Status:
Not open for further replies.
  1. Hi there to everyone.
    I am a complete novice so would welcome some advice.
    I recently bought an IOMEGA 500 GB storage device. if i leave it connected and try booting the computer as normal it comes up with an error message saying unkown device ( a bit like when you leave a floppy disc inserted)
    i therefore have to leave the device disconnected, boot up as normal and then switch it on.
    Not the biggest problem in the world but its annoying.
    how can i leave the storage device permanently connected and switched on.
    I formatted the device when i got it.
    Do i need to alter settings in bios or something.

    Cheers
    Dave
  2. Nodsu

    Nodsu TS Rookie Posts: 9,431

    What kind of storage device exactly are we talking about? A USB mass storage box? External SATA?
  3. wingy999

    wingy999 TS Rookie Topic Starter

    Iomega Hdd

    hi there
    thanks for yr reply. it is a usb mass storage device.

    dave
  4. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,712

  5. Nodsu

    Nodsu TS Rookie Posts: 9,431

    No, it's not drivers, because the error is a boot error. Happens before any drivers or software are loaded.

    Anyway. Wingy: look around in BIOS settings, especially the boot order. Either disable booting from USB devices or set their priority below your hard drive.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.